Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

text font not going to web page defaults

  • 4 replies
  • 2 have this problem
  • 5 views
  • Last reply by engrr

more options

Firefox appears to be using the "options" font type and color, rather than the web page font and color, despite the box being checked to allow the web page font to override the options font

All Replies (4)

more options

Have a look at the following article.

How to fix preferences that won't save

more options

The preferences are saving - I did change the font preference from Times Roman to Arial, and that did change and did save. The problem is that the web page text loads using that font, not the original font and text color on the web page, despite the box being checked "to allow web page to chose their own font". The same web page does show the original font & color if opened in IE10.

I did do a full reset yesterday and that did not help

more options

Make sure that you allow pages to choose their own fonts.

  • Edit > Preferences > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and reset user set (bold) gfx.downloadable_fonts.enabled prefs via the right-click context menu to the default value to make sure that you allow fonts to be downloaded.

more options

Thanks Moses, I did get into about:config and that was set to non-bold with "default; boolean; true", so that seems correct, so still puzzled...