X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Multimedia messaging (MMS) does not work

Posted

The phone is a ZTE Open C that I just received today. The service provider is T-Mobile.

It seems that I am unable to receive multimedia messages. The phone displays this message: "I have sent you a file. It will be available until (date)." When I click on the download button underneath the message, the icon just keeps spinning indefinitely.

I found a couple of pages that seem to be related to the issue I am experiencing: https://support.mozilla.org/en-US/questions/969281 https://bugzilla.mozilla.org/show_bug.cgi?id=898202

However, both of those are from last year. Is there a fix available or a workaround to get multimedia messaging working properly? Thank you.

The phone is a ZTE Open C that I just received today. The service provider is T-Mobile. It seems that I am unable to receive multimedia messages. The phone displays this message: "I have sent you a file. It will be available until (date)." When I click on the download button underneath the message, the icon just keeps spinning indefinitely. I found a couple of pages that seem to be related to the issue I am experiencing: https://support.mozilla.org/en-US/questions/969281 https://bugzilla.mozilla.org/show_bug.cgi?id=898202 However, both of those are from last year. Is there a fix available or a workaround to get multimedia messaging working properly? Thank you.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:29.0) Gecko/20100101 Firefox/29.0

More Information

Question owner

Here is a recent bug report related to this, however the language is over my head: https://bugzilla.mozilla.org/show_bug.cgi?id=999867

If anyone could walk me through fixing this issue, I would greatly appreciate it.

Here is a recent bug report related to this, however the language is over my head: https://bugzilla.mozilla.org/show_bug.cgi?id=999867 If anyone could walk me through fixing this issue, I would greatly appreciate it.
mluna 70 solutions 486 answers

Hi Matej,

Thanks for using Firefox OS. If you disable WiFi, and make sure you have data available, you should be able to get the MMS. Let me know how it goes or if you continue to have this problem.

Thanks, Michelle

Hi Matej, Thanks for using Firefox OS. If you disable WiFi, and make sure you have data available, you should be able to get the MMS. Let me know how it goes or if you continue to have this problem. Thanks, Michelle
Andrew
  • Moderator
321 solutions 4036 answers

Helpful Reply

I have this issue as well. However, it's intermittent for me, hence I'm not sure which version of Firefox OS you're on.

Just make sure Wifi is off and mobile data is turned on before that download button is pressed as it will require the information from the network (your carrier) in order to get the MMS fully.

Thanks!

I have this issue as well. However, it's intermittent for me, hence I'm not sure which version of Firefox OS you're on. Just make sure Wifi is off and mobile data is turned on before that download button is pressed as it will require the information from the network (your carrier) in order to get the MMS fully. Thanks!

Question owner

The OS version is 1.3.0.0.

Before even making this thread, I already tried turning off the Wi-Fi, and it did not work. However, the first time around I did not restart the phone. I tried again, and when I also restarted the phone after turning off the Wi-Fi, it now seems to work. I assume at the moment there is no way to set the priority for the multimedia messages to be downloaded over the mobile network even when Wi-Fi is turned on.

I have also come across a few other little bugs, though I understand the OS is still under development. It seems the main issue of not being able to download multimedia has been resolved for now, as long as I keep the Wi-Fi turned off or restart the phone after turning it off.

Thank you.

The OS version is 1.3.0.0. Before even making this thread, I already tried turning off the Wi-Fi, and it did not work. However, the first time around I did not restart the phone. I tried again, and when I also restarted the phone after turning off the Wi-Fi, it now seems to work. I assume at the moment there is no way to set the priority for the multimedia messages to be downloaded over the mobile network even when Wi-Fi is turned on. I have also come across a few other little bugs, though I understand the OS is still under development. It seems the main issue of not being able to download multimedia has been resolved for now, as long as I keep the Wi-Fi turned off or restart the phone after turning it off. Thank you.
Andrew
  • Moderator
321 solutions 4036 answers

We're more than happy to hear that things are somewhat working now.

If you know you've found a bug, let us know so we can get it on file and to be fixed. You can also file a bug at bugzilla.mozilla.org - post back with the bug # once that has been completed.

Thanks!

We're more than happy to hear that things are somewhat working now. If you know you've found a bug, let us know so we can get it on file and to be fixed. You can also file a bug at bugzilla.mozilla.org - post back with the bug # once that has been completed. Thanks!

Question owner

Here are some of the other bugs and input I have so far:

Bugs: -The new message notifications sometimes do not disappear when I read the SMS, usually when I already have the messaging app open. -When clicking on the new message notification, it sometimes goes to the most recent conversation instead of the correct conversation. -On the Notifications panel, in place where it should show the data usage, it says "No SIM inserted. Insert a SIM to enable Usage," even though I do have a SIM card inserted and it is working properly. Nothing seems to make it go away after it showed up, even restarting the phone or reinstalling the SIM card. Apparently this is already a known bug. -I seem to randomly lose contacts. Not all the contacts, just a few random ones. I imported all the contacts from my old phone to the SIM card and then transferred them to the new phone, yet a few contacts are always missing. I think it is possible that my SIM card may be full and cannot store all the contacts, but I have no way to manage the contacts on it, which leads me to my suggestions below.

Input and suggestions: -It would be nice to have a way to manage contacts and data stored on the SIM card, whether through the Firefox OS or through a USB link when the phone is plugged into the computer. I searched to see if it is possible to already manage the SIM data somehow, but was not able to find anything. -Optional 24-hour time format. I know the time format is automatically determined by the user's selected location, but I always prefer to use 24-hour time format. -A more convenient way to silence the phone when it is ringing. -Ability to turn off vibration completely. Even when I have the phone in the silent mode, it still seems to vibrate when it wants to.

That is what I can think of at the moment. I am sure I will come across more as I keep using Firefox OS. Thank you.

Here are some of the other bugs and input I have so far: Bugs: -The new message notifications sometimes do not disappear when I read the SMS, usually when I already have the messaging app open. -When clicking on the new message notification, it sometimes goes to the most recent conversation instead of the correct conversation. -On the Notifications panel, in place where it should show the data usage, it says "No SIM inserted. Insert a SIM to enable Usage," even though I do have a SIM card inserted and it is working properly. Nothing seems to make it go away after it showed up, even restarting the phone or reinstalling the SIM card. Apparently this is already a known bug. -I seem to randomly lose contacts. Not all the contacts, just a few random ones. I imported all the contacts from my old phone to the SIM card and then transferred them to the new phone, yet a few contacts are always missing. I think it is possible that my SIM card may be full and cannot store all the contacts, but I have no way to manage the contacts on it, which leads me to my suggestions below. Input and suggestions: -It would be nice to have a way to manage contacts and data stored on the SIM card, whether through the Firefox OS or through a USB link when the phone is plugged into the computer. I searched to see if it is possible to already manage the SIM data somehow, but was not able to find anything. -Optional 24-hour time format. I know the time format is automatically determined by the user's selected location, but I always prefer to use 24-hour time format. -A more convenient way to silence the phone when it is ringing. -Ability to turn off vibration completely. Even when I have the phone in the silent mode, it still seems to vibrate when it wants to. That is what I can think of at the moment. I am sure I will come across more as I keep using Firefox OS. Thank you.

Modified by MatejBlahut

blacklodge 0 solutions 1 answers

I bought the ZTE Open C in France in september and I cannot receive MMS too. I can send them though. I did some tests with a friend and both my carrier and my friend's is Free Mobile. My friend can read the MMS I send to him (he has an Android phone).

I installed all the updates the phone found to this date (20 sept 2014). I looked at the MMS settings and everything seems correct.

EDIT: I found that bug that seems to match my problem: https://bugzilla.mozilla.org/show_bug.cgi?id=1031656

I bought the ZTE Open C in France in september and I cannot receive MMS too. I can send them though. I did some tests with a friend and both my carrier and my friend's is Free Mobile. My friend can read the MMS I send to him (he has an Android phone). I installed all the updates the phone found to this date (20 sept 2014). I looked at the MMS settings and everything seems correct. EDIT: I found that bug that seems to match my problem: https://bugzilla.mozilla.org/show_bug.cgi?id=1031656

Modified by blacklodge

Andrew
  • Moderator
321 solutions 4036 answers

blacklodge,

Please open a new support ticket by clicking here if you want us to look into your issue for you. You're posting on a thread that is dated back in May, which is possibly outdated.

Thanks for your cooperation.

blacklodge, Please open a new support ticket by clicking [/questions/new here] if you want us to look into your issue for you. You're posting on a thread that is dated back in May, which is possibly outdated. Thanks for your cooperation.