Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes

  • 3 replies
  • 1 has this problem
  • 27 views
  • Last reply by Raviteja14

more options

Installed windows 8 (upgraded from 7) and firefox started forcing closing when ever I login in gmail.Tried fresh install of browser still same.

Chosen solution

Have you had trouble anywhere else then gmail?

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache

Press the <Alt> or <F10> key to bring up the tool bar. Then; Tools > Options > Advanced > Network > Cached Web Content: Clear Now

and

  • Remove Cookies

Press the <Alt> or <F10> key to bring up the tool bar. Then Tools > Options > Privacy.

Under History, select Firefox will Use Custom Settings. There is a button on the right side called Show Cookies.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode; Press the <Alt> or <F10> key to bring up the tool bar.. Then Tools > Options > Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites and see if there is still a problem. Then restart.

Read this answer in context 👍 2

All Replies (3)

more options

Firefox 29 is brand new so expect some bugs. Seems like your issue continues, I would temporarly revert back to Firefox 28, and wait for a new update. Sorry to hear reinstalling didn't work. Firefox 28

more options

Chosen Solution

Have you had trouble anywhere else then gmail?

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache

Press the <Alt> or <F10> key to bring up the tool bar. Then; Tools > Options > Advanced > Network > Cached Web Content: Clear Now

and

  • Remove Cookies

Press the <Alt> or <F10> key to bring up the tool bar. Then Tools > Options > Privacy.

Under History, select Firefox will Use Custom Settings. There is a button on the right side called Show Cookies.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode; Press the <Alt> or <F10> key to bring up the tool bar.. Then Tools > Options > Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites and see if there is still a problem. Then restart.

more options

Thanks it worked