Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Since downloading 29.0.1 I can no longer cut, copy and paste. So frustrating!!!

  • 16 replies
  • 12 have this problem
  • Last reply by karenbills

more options

I often copy and paste items into website forums with no problem. However, since I upgraded to 29.0.1 I can no longer do that and it's so frustrating. I have tried doing the extra steps of clicking on your copy and paste items but that doesn't help. I even tried uploading the AllowClipboard Helper but that didn't work either. I never needed that add-on in the past.

This is ridiculous.

How do I revert back to version 28? It worked fine but you just had to go ahead and "fix" it and I hate the new version. I was able to download the Classic Theme Restorer which helped a lot but some things I could not make like the version 28.

Chosen solution

Hi karenbills, actually, the fox icon is part of the Title Bar. In order to display the Title Bar, you can use the Customize feature and click the Title Bar button at the lower left. However, it does add another line of height to the toolbar area, which I suspect is why it is not shown by default.

Read this answer in context 👍 1

All Replies (16)

more options

Hello karenbills, we can see in your system details that you have in your profile folder a User.js file.

The user.js file does not exist by default. If you create the file, forget it, if you have not create the file then delete the User.js file(some programs create and write in the file also), and check again if the issue exist.

thank you

more options

Is that about pasting in a rich text editor or in a normal text area like this website uses?

Use keyboard shortcuts if the buttons on the web page or other methods aren't working.

  • Copy: Ctrl+C or Ctrl+Insert (Mac: Command + C)
  • Paste: Ctrl+V or Shift+Insert (Mac: Command + V)
  • Cut: Ctrl+X or Shift+Delete (Mac: Command + X)
more options

Starting with Firefox 29, copy/cut/paste buttons on rich text editors no longer works. Use the keyboard shortcuts instead. I have asked developers to restore the functionality in a bug. For the meantime, you can instead install Firefox ESR to continue using the buttons.

more options

Thanks everyone for your suggestions. I didn't understand how to do any of them but now everything seems to be okay once again so I don't know why I had the problem.

ideato - I did a search of my C: drive and could not find any file called User.js

cor-el - It was pasting in a window like this one on a website. In fact I just tried pasting something in this window and it worked just fine. Weird.

cor-el and Kohei - I always use the keyboard shortcuts. I wasn't even aware there was any other way to do it.

more options

Hi karenbills and anyone else reading:

What Kohei is referring to is that websites are restricted from using JavaScript to modify your clipboard. Before Firefox 29, there was a way to create site-specific exceptions to this restriction, but that mechanism was removed starting in Firefox 29.

This should not affect your standard operating system shortcuts or Firefox's right-click menu.

more options

Thanks, jscher2000, now I understand better. So the User.js file means that the js stands for JavaScript, which I don't think I need anyway, right?

Now can anyone tell me how to get back the orange firefox icon? I figured out how to get the Classic look back but not all of it is classic. I now have in the top left corner of my screen a rectangular drop down box that I have been able to make orange color but cannot find a way to get the old icon back, with the orange fox wrapped around the world. I don't even need that drop down menu. It's just a repetition of other items in the top bar, which is the menu bar.

more options


You don't need that user.js file any longer for those cut, copy, and paste preferences.

There is a Classic Theme Restorer support thread over here.
They'll be able to help you get rid of that orange Firefox button, which isn't needed if you have the Menu Bar showing.

more options

Thanks, Ed. I'll go other to that thread.

more options

Hi karenbills, the user.js file, if one exists, contains preference settings that Firefox reads at startup and uses to override your previous session settings. Usually you won't have a user.js file because most preferences can be entered in the about:config editor. The old clipboard policy exceptions were not possible to enter through about:config, so those needed to be put in a user.js file or in the standard prefs.js file.

more options

Note that in the previous Firefox version you got the orange Firefox menu button when the menu bar was hidden.

In the current Firefox 29 release, that have have the Australis interface, the orange Firefox menu button has been replaced by the three bar Firefox Menu button at the far right end of the Navigation Toolbar and this button is always visible, whether you have the menu bar visible or hidden
A consequence of this location is that you no longer can hide the Navigation Toolbar

  • There is a star like button to the right end of the search bar on the Navigation Toolbar to bookmark the current web page and a "Show your bookmarks" button next to it to open the Bookmarks in a drop down menu.
    You can find "Show All Bookmarks" to open the Bookmarks Manager (Library) at the bottom of this drop-down list
  • It is still possible to have the menu bar visible via the right-click context menu on the toolbars to have menus like the Bookmarks menu

You can look at the Classic Theme Restorer extension to restore some functionality that was lost with the arrival of the Australis style in Firefox 29.

  • You can check out the settings of the CTR extension via its Options/Preferences button on the "Firefox/Tools > Add-ons > Extensions" page.
  • You can find extra toolbar buttons and more toolbar settings in Customize (3-bar Firefox menu button > Customize)

See also:

more options

This is the single most frustrating, ridiculous, incredible mess ever for Firefox. To take away the workarounds that allowed cut and paste is insane. Let people control their own browsers and stop shutting down the remaining workarounds that still functioned. We are not children. Let us decide whether to take the risk or not. For me, an original FF user from the start, I am fed up with this latest version. To not have cut and paste work in Wordpress anymore is insanity! Does anyone know a way to fix it now that Clipboard Helper fails? I am concerned about implementing the javascript workaround I see posted as the only remaining option now that redoing the FF configuration file doesn't seem to work anymore.

more options

youthchange - Glad you agree with me. Another thing I don't understand is why we have to come to this website to try to find help from other users!! Why can't Mozilla answer us?

One of the reasons I don't normally use Chrome is I hate the way it's configured with the tabs on the top and no way to make it work like Firefox. I.E. is too slow so I rarely resort to it either. This is ridiculous.

Thanks to everyone who has responded to my question. Most of your answers are beyond my comprehension though but I appreciate your willingness to help me.

If I could go back to Firefox 28 I would as there was nothing wrong with it. Now I'm kicking myself for allowing the upgrade.

more options

The "menu" bar is where it says "File Edit View History Bookmarks Tools and Help" up at the top of each page, right?

Well I always had the orange Firefox icon to the left of that and now I just have the Firefox orange drop down menu that I don't need or want. I want the Fox back but cannot figure out how to get it. I tried going to that other website Mozillalink (or something like that) but got no help there.

more options

Hi karenbills, are you using Classic Theme Restorer?

You can turn off the orange "Firefox" button in its settings. It's in the section called "Application button". See the attached screen shot.

I'm not sure you can get the small Firefox icon back in the corner, though. I haven't looked into it in detail.

more options

Chosen Solution

Hi karenbills, actually, the fox icon is part of the Title Bar. In order to display the Title Bar, you can use the Customize feature and click the Title Bar button at the lower left. However, it does add another line of height to the toolbar area, which I suspect is why it is not shown by default.

more options

Thanks so much, J. Yes I'm using the Classic Theme Restorer but it didn't restore everything as it was before the upgrade. I now have the title bar back with the fox icon and I also got rid of the superfluous Firefox button with drop down menu.

THANKS TO EVERYONE HERE. No thanks to Mozilla for foisting this on us.