This forum is a discussion about improving the "Websites say that Firefox is outdated or incompatible even though it's the latest version" article. If you'd like to participate, please register.

If you need help with Firefox, please ask a question.