View PDF files in Firefox

Revision Information
  • Revision id: 795
  • Created:
  • Creator: Chris Ilias
  • Comment: specify that "Only the first page is visible" only applies to Leopard and below. Apple removed it in QTX
  • Reviewed: No
  • Ready for localization: Yes
  • Readied for localization by: AnonymousUser
Revision Source
Revision Content

Adobe does not yet maintain a plugin for viewing PDF files within Firefox for computers with Mac OS X. To view PDFs in Firefox:

Only the first page is visible (Mac 10.5 and below)

If PDF documents open within Firefox but only the first page is viewable, make sure that the QuickTime plugin isn't set to handle PDF content:

  1. From the Apple menu, choose System Preferences.
  2. From the View menu, choose QuickTime.
  3. Click the Plug-In tab and click MIME settings....
  4. In the list of MIME types, click the triangle next to "Images - Still image files".
  5. If "PDF Image" is checked, click the check box to clear it.
  6. Click OK

The Adobe Reader plugin can be used to display PDF file inside the Firefox browser window. If there is a problem with the plugin, it may become impossible to do this. When you try to view a PDF, Firefox may try to download it instead.

For more information on the Adobe Reader plugin, see Use Adobe Reader to view PDF files in Firefox.


Check Firefox settings

  1. Click the menu button New Fx Menu Fx57Menu and choose Options.Preferences.
  2. Select the Applications panel.
  3. Find Adobe Acrobat Document in the list and click on it to select it.
  4. Click on the drop-down arrow in the Action column for the Adobe Acrobat Document entry and select Use Adobe Acrobat (in Firefox).

    c77e7a43631723daa6760be30a717e46-1258906074-116-1.png
    • If Use Adobe Acrobat (in Firefox) is not listed as an Option, see Reset download actions below and then repeat this set of instructions.
  1. Close the about:preferences page. Any changes you've made will automatically be saved.

Now try to view a PDF in Firefox. If it opens in the browser window, the problem is solved. If not, continue with the following instructions.

Reset download actions

  1. Open your profile folder:

    Click the menu button Fx57menu , click Help and select Troubleshooting Information.From the Help menu, choose Troubleshooting Information. The Troubleshooting Information tab will open.

    • Under the Application Basics section, click on Open FolderShow in FinderOpen Directory. A window will open that contains your profile folder.Your profile folder will open.
    Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.

  2. Click the menu button New Fx Menu and then click ExitQuit Close 29 .

    Click the Firefox menu Fx57Menu , then click Exit. Click the Firefox menu at the top of the screen, then click Quit Firefox.Click the Firefox menu Fx57Menu , then click Quit.

  3. Delete the mimetypes.rdf file.

Check Adobe Reader settings

  1. Open Adobe Reader.
  2. Once in Adobe Reader, click the Edit menu in the menu bar, and then click Preferences... The Preferences window will open.
  3. In the Categories section, click on Internet.
  4. Make sure the first check box, Display PDF in browser, is checked.
  5. Click OK to dismiss the Preferences window, and then close Adobe Reader.

Now try to view a PDF. If it opens in the browser window, the problem is solved. If not, continue with the next troubleshooting instructions.

Re-install the plugin

  1. Close Firefox.
  2. Open the Adobe Reader installation folder. This can be done by using Windows Explorer to navigate to C:\Program Files\Adobe\Reader 9.0\Reader\, assuming Reader 9 is installed in the default location.
  3. Open the Browser sub-folder inside the Adobe Reader installation folder.
  4. Copy the nppdf32.dll file to the Firefox plugins folder: Right-click the file and then click Copy from the context menu. Then use Windows Explorer to navigate to your Firefox installation's plugins folder (e.g. C:\Program Files\Mozilla Firefox\plugins). Right-click in the file list and click Paste.
  5. Open Firefox and in the address bar type about:plugins to bring up the Firefox plugins list.
  6. Look for the Adobe Acrobat entry.

If the entry is there, try to view a PDF. If it opens in the browser window, the problem is solved. If not, follow the next set of troubleshooting instructions.

Re-initialize the plugins database

Follow the instructions in the Re-initializing the plugins database section of the Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems article.

This will force Firefox to rebuild its plugin database. Now try to view a PDF in Firefox. If it opens in the browser window, the problem is solved.

Re-install Adobe Reader

If the above troubleshooting methods for Firefox did not work, uninstall and re-install Adobe Reader:

Further information

If none of the above troubleshooting methods worked, see Adobe's troubleshooting page for further instructions.