Upgrading from Thunderbird 3.1

As of April 24, 2012, Mozilla will no longer support Thunderbird version 3.1. This means we will no longer provide enhancements or bug fixes (including security and performance fixes). While you can continue to use Thunderbird 3.1, we strongly recommend that you upgrade Thunderbird to the latest version. This is why you will see a note saying that:

This version of Thunderbird will be obsolete from April 24th, 2012. You will no longer have the benefit of security and stability enhancements, therefore you will be at greater risk of security vulnerabilities and attack. We strongly recommend that you get the newest version now.

To check which version of Thunderbird you are running, select Help | AboutHelp | About ThunderbirdThunderbird | About Thunderbird

This article answers frequently asked questions about upgrading from Thunderbird 3.1 to the latest version.

How to Upgrade from Thunderbird 3.1

(For those of you who prefer video, please refer to our Thunderbird 3.1 Upgrade Video below. Even if you watch the video, we strongly recommend reading the following explanatory text and screenshots which complement and supplement the material in the video.)

The upgrade has four steps:

  1. Back up your data
  2. Upgrade Thunderbird
  3. Check add-on compatibility
  4. Review new features

1. Backup your Thunderbird Data

While it is not strictly necessary to make a backup of your messages and settings (which we refer to as a "Thunderbird profile" or simply as a "profile"), we recommend that you do so before proceeding with the upgrade.

To back up your data, copy your profile to another location (for example, to another directory on your local drive or onto a backup device such as a USB stick or external hard drive):

  1. Close Thunderbird.
  2. Find your Thunderbird profile on Mac, Windows, and Linux.
  3. Copy the profile directory to another location.

2. Upgrade Thunderbird 3.1 to the current version

Note that latest releases of Thunderbird (starting with Thunderbird 5) are not compatible with MAC OS X 10.4. You must update MAC OS to a more recent release in order to upgrade Thunderbird.

1. Click Help | Check for Updates... 1. Click Thunderbird | Check for Updates... Help Check for Updates Get the New Version

Thunderbird will start downloading.
Downloading Update

3. When the download is complete, Thunderbird will say Update Ready to Install. Click Restart Thunderbird Update Ready to Install

4. On Windows 7 and Vista you will also see a User Account Control prompt for the Thunderbird Upgrade which you should also accept.

On Linux, the situation depends on which version of the distribution you use. Note that if you use a supported release of Ubuntu, you will be automatically updated to the last release of Thunderbird. However, there is a delay between Thunderbird's official update and the moment when it is made available to all Ubuntu users through the Software Center (generally, 2 or 3 weeks). If you want to be updated faster, then you can either:

  • add to your repositories the ppa called ppa:mozillateam/thunderbird-stable in order to get the new version of Thunderbird. See this article for more details.


3. Check add-on compatibility

After downloading, installing and restarting the latest version of Thunderbird, Thunderbird will perform an add-on compatibility check.

Most Thunderbird add-ons have been updated to the current version, but you may still have add-ons that are not compatible. To check, select Tools| Add-ons.

Thunderbird will display a dialog that shows all your add-ons and their upgrade status. Select or disable add-ons then click Next. You will be prompted to confirm your selection.

  


Select your Add-ons


Thunderbird will now update the add-ons you chose to update. Update your Add-ons

4. Review New Features

Thunderbird will restart. New features are summarized on the Start Page, which is displayed in a new tab: New Start Page edit

Mozilla uses the Thunderbird Start Page to communicate tips, service notices and other important information. We recommend that you configure it to be displayed every time Thunderbird starts.

At the top of the Firefox window, click on the Firefox button and then select OptionsAt the top of the Firefox window, click on the Tools menu and then select OptionsOn the menu bar, click on the Firefox menu and select Preferences...At the top of the Firefox window, click on the Edit menu and select Preferences

Click the menu button New Fx Menu and choose OptionsPreferences

and click Restore Default.

For details about the changes in Thunderbird since version 3.1, see New in Thunderbird.

Thunderbird 3.1 Upgrade Video

For those of you who prefer video, here's a Thunderbird 3.1 upgrade video. Even if you watch the video, we strongly recommend reading the material above because it is explanatory text and screenshots which complement and supplement the material in the video.

The video "TB 3.1 Upgrade Video" does not exist.

Add-on compatibility

Thunderbird add-ons are optional extensions to Thunderbird that are written and maintained by volunteers. While most add-ons are distributed through the Mozilla add-ons site and are validated and approved by Mozilla, some are distributed independently outside of the official Mozilla channels. In all cases, Mozilla is not responsible for supporting or updating add-ons.

Some third-party add-ons have not been updated by their authors to be compatible with Thunderbird versions greater than 3.1. These are listed below. Note that there may be other add-ons that are similarly incompatible but that we do not know about. If you encounter an incompatible add-on, please edit this page and add it to the list. Alternatively, leave a comment to this article that mentions the incompatible add-on.

In some cases, people have written new add-ons to replace add-ons that are no longer functional. Where we are aware of these, we have listed the alternatives below. The replacement add-ons may not have identical functionality to the original add-on.

The upgrade process includes a step that checks add-on compatibility. Incompatible add-ons will be disabled, even if they are not listed below.

Known Incompatible Add-ons

To upgrade to a replacement add-on:

  1. Perform the Thunderbird upgrade. Accept any extension incompatibility.
  2. Install the replacement add-on using the Add-ons manager (Tools | Add-ons).
  3. Uninstall the old add-on (to avoid future compatibility prompts).

Was this article helpful? Please wait...

These fine people helped write this article: . You can help too - find out how.