Compare Revisions

Switching to Thunderbird

Revision 125716:

Revision 125716 by MozGianluc on

Revision 127160:

Revision 127160 by Tonnes on

Keywords:

"windows mail" windows "windows live mail" mac evolution webmail switching migration
"windows mail" windows "windows live mail" mac evolution webmail switching migration

Search results summary:

This article explains how you can switch to Thunderbird from your current mail application, such as Windows Mail, Outlook or also Mail on Mac OS and Evolution on Linux.
This article explains how you can switch to Thunderbird from your current mail application, such as Windows Mail or Outlook, Mail on Mac OS, or Evolution on Linux.

Content:

__TOC__ {for mac} = Switching from Apple Mail to Thunderbird = Thunderbird can import your messages and OS X address book, but it cannot import your account settings. (Currently, message and address book import is only functional with Apple Mail 5.0 or earlier.) == Importing Apple Mail messages == # On the menu bar, open the {menu Tools} menu and click on {menu Import}. The import wizard will open.<br><br>[[Image:mac-toolsimport]] <br><br> # Select '''Mail''' then click {button Next}.<br><br>[[Image:mac-importwizard]] <br><br> # Select '''Apple Mail''' then click {button Next}.<br><br>[[Image:mac-importmail]] <br><br> # You will see a log of successfully imported folders, then click {button Finish} to close the import wizard.<br><br>[[Image:mac-mailimportedsuccess]] Your imported messages will appear in the Local Folders account, in a folder called "''Apple Mail Import''".<br> [[Image:mac-whereimportedmail]] == Importing the OS X address book == Thunderbird will read your OS X address book and display it in the Thunderbird address book window! From the menu bar, open the {menu Window} menu and click on {menu Address Book}. Your OS X address book will appear in the left pane. <br>[[Image:mac-OSXaddressbook]] If you want to import it to the Thunderbird address book, just drag and drop entries from the Mac OS X address book folder to the Personal Address Book. {note}'''Note:''' You can select all entries at once by holding down the {key command} key and pressing {key A}.{/note}{/for} {for win} = Switching from Windows Mail or Windows Live Mail to Thunderbird = Windows Mail is the default mail client included with Windows Vista. Windows Live Mail is the email client bundled with Windows Live Essentials. Both client programs store emails in the .eml file format. In order to export messages from Windows Mail or Windows Live Mail to Thunderbird, you must export messages from the Windows application and import them into Thunderbird. A similar method is needed to export contacts from Windows Mail or Windows Live Mail to Thunderbird. To find the location of the email files in Windows Mail or Windows Live Mail, go to {menu Tools > Options > Advanced > Maintenance > Store Folder}. == Importing Windows Mail Messages == Importing Windows Mail (.eml files) into Thunderbird is enabled by the third-party add-on ImportExport Tools. [https://addons.mozilla.org/thunderbird/addon/importexporttools/ Download] and install this add-on to transfer messages from Windows Live Mail to Thunderbird. #Export your messages from Windows Mail in .eml format. #In Thunderbird, go to {menu Tools > ImportExport > Import all messages from a directory > Also from its subdirectories}. #Navigate to the .eml files folder. The default location for Windows Live mail is {filepath C:\Users\<username>\AppData\Local\Microsoft\Windows Live Mail} (or \Windows Mail).NOTE: To be able to see the folder "App Data" you must first change Folder Options to "Show hidden files, folders, and drives" #Click {button Open}. Your data will be imported. == Importing Windows Mail Contacts == In order to import Windows contacts into Thunderbird, you must export the contacts to a text file (.csv format) and import the file into Thunderbird. See the [http://windows.microsoft.com/en-US/windows7/Import-export-or-change-the-format-for-contacts Import, export, or change the format for contacts] article at Microsoft.com for instructions on how to export contacts in Windows 7. After creating the required file, you can import your contacts using the [[Switching to Thunderbird from Windows or Web-Based Email Applications#Importing Outlook 2007 Contacts/Address Book|instructions for importing Outlook 2007 contacts]] below. However, instead of choosing ''Outlook'' in step 3, choose ''Text file (LDIF, .tab, .csv, .txt)'' and click {button Next}. In the Select address book file window that appears, select ''Comma Separated'' (or ''All files'') in the drop-down list at the bottom right, browse to the .csv file you just created, select it and click Open. In the Import Address Book window that appears, use the Move Up and Move Down buttons to match the address book fields on the left to the correct data for import on the right, and uncheck items you do not want to import. When you are done, click OK. Your contacts should now be imported and ready for use in Thunderbird. Note that if you are having problems importing the fields properly (like when all record data to import shows up inside the first field row when inside the Import Address Book window), this is probably a result of an exported .csv file containing semicolons instead of commas, or the other way around. This usually happens because the separator in Windows Regional settings does not match the one for the Thunderbird locale, for instance when you exported a .csv file using an English Windows version and try to import it into a non-English version of Thunderbird. In this case, you should make the list separator match in your Regional settings before exporting the .csv file, or you could edit the already exported .csv file using a text editor and replace all semicolons by commas (or vice versa), and retry the import step. = Importing from Outlook and Eudora = Unfortunately, Outlook and Eudora import wizard is broken since version 38. For the time being, the only solution available is to downgrade to [https://ftp.mozilla.org/pub/thunderbird/releases/31.8.0/win32/en-US/ version 31.8] which is the latest version working, importing and then upgrading back to the latest version of Thunderbird via the built-in [[Updating Thunderbird|update mechanism]]. <!--== Switching from Outlook 2007 to Thunderbird == The following instructions describe how to import messages and contacts from Outlook 2007. == Importing Outlook 2007 Messages == In order to import messages from Outlook to Thunderbird, Outlook must be the default mail client. #In Thunderbird, go to {menu Tools > Import…}. <br> #Choose Mail and click {button Next}. <br> <br> [[Image:1e78f7f724ed9295cabef9d653f02e6b-1280168514-828-2.png]] <br> <br> #Choose Outlook and click {button Next} to start the import process. <br> <br> [[Image:1e78f7f724ed9295cabef9d653f02e6b-1280168514-828-1.png]] <br> <br> #The Import Wizard will process the emails and display the results. Click {button Finish}. <br> <br> [[Image:1e78f7f724ed9295cabef9d653f02e6b-1280168514-828-3.png]] <br> The emails will now be stored in a folder called '''Outlook Import''' under the '''Local Folders''' directory. <br> <br> [[Image:1e78f7f724ed9295cabef9d653f02e6b-1280168514-828-4.png]] == Importing Outlook 2007 Contacts/Address Book == #In Thunderbird, go to {menu Tools > Import…}. #Choose Address Books and click {button Next}. <br> <br> [[Image:1e78f7f724ed9295cabef9d653f02e6b-1280177119-49-1.png]] <br> <br> #Choose Outlook and click {button Next}. <br> <br> [[Image:1e78f7f724ed9295cabef9d653f02e6b-1280177119-49-2.png]] <br> <br> #Wait for the import to finish and click {button Finish}. <br> <br> [[Image:1e78f7f724ed9295cabef9d653f02e6b-1280177119-49-3.png]] <br> ==Importing PST files== Thunderbird cannot import a standalone PST file. Mail import from Outlook works by using the Outlook program to source the emails, not the underlying PST file. If you are switching to Thunderbird and will no longer have a copy of Outlook then it will be necessary to convert all of your existing PST backup files to Thunderbird while you still have access to Outlook on the same computer as Thunderbird.--> {/for} {for linux} = Switching from Evolution to Thunderbird = The following instructions describe how to import messages and contacts from Evolution. == Importing Evolution Messages == Thunderbird and Evolution use the same file format (called mbox) to store your mails, so its not difficult to import them manually. #Open Nautilus. #Open {filepath ~/.local/share/evolution/mail/local} which is where Evolution store your mails. #Copy all the file without extension (such as '''Inbox''', '''Outbox''',..) into the emplacement used by Thunderbird to store its mail (something like {filepath ~/.thunderbird/uk41lql0.default/Mail/Local Folders},where you need to adapt ''uk41lql0.default'' to your own installation). #Launch Thunderbird to check that all your mail have been correctly imported. == Importing Evolution Contacts == #Open your address book in Evolution, right-click on it and choose: '''Save as vcard...''' to export it into vCard file format. #Import this file into Thunderbird: #* In Thunderbird 3 and 3.1, you need to install the [http://nic-nac-project.de/~kaosmos/morecols-en.html MoreFunctionForAddressBook] extension in order to be able to import vCard file. Once this is done, open the Address book window, right click on the entry area and select Import vCard/vcf. Select the .vcf file that you have just saved. #* In Thunderbird 5 or above, open the {menu Tools > Import...} menu, select '''Address Books''' and then '''vCard file ( *.vcf)''' and select your contact file. {/for} = Switching from Web-based Email Applications to Thunderbird = If you are using a web-based application provided by your Internet Service Provider (ISP) to access your email, you probably only need to configure your account information to switch to Thunderbird. See [[Configure an Account]] for instructions. Also, see [[ISP Configuration Settings]] for instructions on specific ISPs. Once you have configured your account in Thunderbird, you should be able to access all your messages (both incoming and sent). However, your address book (contacts), mail filters and other settings will not be automatically transferred to Thunderbird. Some web-base email applications allow you to export contacts in text or comma-separated formats. Check your ISP's documentation for more information. To import contacts into Thunderbird, select {menu Tools > Import…} and follow the instructions on the screen. =See Also= * [http://en.flossmanuals.net/thunderbird/ch014_account-set-up/ Account Setup chapter] in the Thunderbird FLOSS manual * [http://en.flossmanuals.net/thunderbird/migrating/ Migrate to Thunderbird chapter] in the Thunderbird FLOSS manual
__TOC__ {for mac} = Switching from Apple Mail to Thunderbird = Thunderbird can import your messages and OS X address book, but it cannot import your account settings. (Currently, message and address book import is only functional with Apple Mail 5.0 or earlier.) == Importing Apple Mail messages == 1. On the menu bar, open the {menu Tools} menu and click on {menu Import}. The import wizard will open. ;[[Image:mac-toolsimport]] 2. Select '''Mail''', then click {button Next}. ;[[Image:mac-importwizard]] 3. Select '''Apple Mail''', then click {button Next}. ;[[Image:mac-importmail]] 4. You will see a log of successfully imported folders. Click {button Finish} to close the import wizard. ;[[Image:mac-mailimportedsuccess]] Your imported messages will appear in the Local Folders account, in a folder called "''Apple Mail Import''".<br> [[Image:mac-whereimportedmail]] == Importing the OS X address book == Thunderbird will read your OS X address book and display it in the Thunderbird address book window! From the menu bar, open the {menu Window} menu and click on {menu Address Book}. Your OS X address book will appear in the left pane. <br>[[Image:mac-OSXaddressbook]] If you want to import it to the Thunderbird address book, just drag and drop entries from the Mac OS X address book folder to the Personal Address Book. {note}'''Note:''' You can select all entries at once by holding down the {key command} key and pressing {key A}.{/note} {/for} {for win} = Switching from Windows Mail or Windows Live Mail to Thunderbird = Windows Mail is the default mail client included with Windows Vista. Windows Live Mail is the email client bundled with Windows Live Essentials. Both client programs store emails in the .eml file format. In order to export messages from Windows Mail or Windows Live Mail to Thunderbird, you must export messages from the Windows application and import them into Thunderbird. A similar method is needed to export contacts from Windows Mail or Windows Live Mail to Thunderbird. To find the location of the email files in Windows Mail or Windows Live Mail, go to {menu Tools > Options > Advanced > Maintenance > Store Folder}. == Importing Windows Mail Messages == Importing Windows Mail (.eml files) into Thunderbird is enabled by the third-party add-on ImportExport Tools. [https://addons.mozilla.org/thunderbird/addon/importexporttools/ Download] and install this add-on to transfer messages from Windows Live Mail to Thunderbird. #Export your messages from Windows Mail in .eml format. #In Thunderbird, go to {menu Tools > ImportExport > Import all messages from a directory > Also from its subdirectories}. #Navigate to the .eml files folder. The default location for Windows Live mail is {filepath C:\Users\<username>\AppData\Local\Microsoft\Windows Live Mail} (or \Windows Mail).NOTE: To be able to see the folder "App Data" you must first change Folder Options to "Show hidden files, folders, and drives" #Click {button Open}. Your data will be imported. == Importing Windows Mail Contacts == In order to import Windows contacts into Thunderbird, you must export the contacts to a text file (.csv format) and import the file into Thunderbird. See the [http://windows.microsoft.com/en-US/windows7/Import-export-or-change-the-format-for-contacts Import, export, or change the format for contacts] article at Microsoft.com for instructions on how to export contacts in Windows 7. After creating the required file, you can import your contacts using the [[Switching to Thunderbird from Windows or Web-Based Email Applications#Importing Outlook 2007 Contacts/Address Book|instructions for importing Outlook 2007 contacts]] below. However, instead of choosing ''Outlook'' in step 3, choose ''Text file (LDIF, .tab, .csv, .txt)'' and click {button Next}. In the Select address book file window that appears, select ''Comma Separated'' (or ''All files'') in the drop-down list at the bottom right, browse to the .csv file you just created, select it and click Open. In the Import Address Book window that appears, use the Move Up and Move Down buttons to match the address book fields on the left to the correct data for import on the right, and uncheck items you do not want to import. When you are done, click OK. Your contacts should now be imported and ready for use in Thunderbird. Note that if you are having problems importing the fields properly (like when all record data to import shows up inside the first field row when inside the Import Address Book window), this is probably a result of an exported .csv file containing semicolons instead of commas, or the other way around. This usually happens because the separator in Windows Regional settings does not match the one for the Thunderbird locale, for instance when you exported a .csv file using an English Windows version and try to import it into a non-English version of Thunderbird. In this case, you should make the list separator match in your Regional settings before exporting the .csv file, or you could edit the already exported .csv file using a text editor and replace all semicolons by commas (or vice versa), and retry the import step. = Importing from Outlook and Eudora = The normal Thunderbird import process requires that you have Eudora or Outlook installed on your computer. If you do not have them installed, there are alternatives as noted below. To use Thunderbird's import wizard, you must use an older version of Thunderbird, because the wizard is broken in Thunderbird version 38 and newer versions. Install [https://ftp.mozilla.org/pub/thunderbird/releases/31.8.0/win32/en-US/ version 31.8], import your data, then upgrade to the latest version of Thunderbird via the built-in [[Updating Thunderbird|update mechanism]]. For Eudora, if you have data problems or crashes, try an even [http://ftp.mozilla.org/pub/thunderbird/releases/17.0.9esr/win32/en-US/ older version of Thunderbird] and a tool to clean the data. An example of a data cleaning tool for Mac OS is [http://andreasamann.com/MacOSX/Eudora_Mailbox_Cleaner Eudora Mailbox Cleaner]. An alternative to Thunderbird's import wizard is to find a tool to transform your data to mbox format (.mbx), and then use [https://freeshell.de//~kaosmos/mboximport-en.html Import Export Tools] add-on in Thunderbird to import the mbox files. One such mbox conversion tool for Eudora is [http://qwerky.50webs.com/eudorarescue/ Eudora Rescue]. == Eudora is not installed == If Eudora is not installed and you want to use the Thunderbird import wizard, you can easily change the Windows registry to point to your Eudora files, then run the import wizard. * Create a [https://support.microsoft.com/en-us/kb/310516 .reg file] called eudora.reg containing the following lines. Replace H:\\SCRATCH\\Eudoradata with the location of your Eudora data. (note the double backslashes and the blank line) <code> === Registry file, adjust file location as required === Windows Registry Editor Version 5.00 [HKEY_CURRENT_USER\Software\Qualcomm\Eudora\CommandLine] "Current"="Anything H:\\SCRATCH\\Eudoradata Anything" === </code> * In a Windows command prompt, run "regedit /s eudora.reg". * Use the Thunderbird import wizard. <!--== Switching from Outlook 2007 to Thunderbird == The following instructions describe how to import messages and contacts from Outlook 2007. == Importing Outlook 2007 Messages == In order to import messages from Outlook to Thunderbird, Outlook must be the default mail client. 1. In Thunderbird, go to {menu Tools > Import…}. 2. Choose Mail and click {button Next}. ;[[Image:1e78f7f724ed9295cabef9d653f02e6b-1280168514-828-2.png]] 3. Choose Outlook and click {button Next} to start the import process. ;[[Image:1e78f7f724ed9295cabef9d653f02e6b-1280168514-828-1.png]] 4. The Import Wizard will process the emails and display the results. Click {button Finish}. ;[[Image:1e78f7f724ed9295cabef9d653f02e6b-1280168514-828-3.png]] The emails will now be stored in a folder called '''Outlook Import''' under the '''Local Folders''' directory. ;[[Image:1e78f7f724ed9295cabef9d653f02e6b-1280168514-828-4_2.png]] == Importing Outlook 2007 Contacts/Address Book == 1. In Thunderbird, go to {menu Tools > Import…}. 2. Choose Address Books and click {button Next}. ;[[Image:1e78f7f724ed9295cabef9d653f02e6b-1280177119-49-1.png]] 3. Choose Outlook and click {button Next}. ;[[Image:1e78f7f724ed9295cabef9d653f02e6b-1280177119-49-2.png]] 4. Wait for the import to finish and click {button Finish}. ;[[Image:1e78f7f724ed9295cabef9d653f02e6b-1280177119-49-3.png]] ==Importing PST files== Thunderbird cannot import a standalone PST file. Mail import from Outlook works by using the Outlook program to source the emails, not the underlying PST file. If you are switching to Thunderbird and no longer have a copy of Outlook, then it will be necessary to convert all of your existing PST backup files to Thunderbird while you still have access to Outlook on the same computer as Thunderbird.--> {/for} {for linux} = Switching from Evolution to Thunderbird = The following instructions describe how to import messages and contacts from Evolution. == Importing Evolution Messages == Thunderbird and Evolution use the same file format (called mbox) to store your mails, so its not difficult to import them manually. #Open Nautilus. #Open {filepath ~/.local/share/evolution/mail/local} which is where Evolution store your mails. #Copy all the file without extension (such as '''Inbox''', '''Outbox''',..) into the emplacement used by Thunderbird to store its mail (something like {filepath ~/.thunderbird/uk41lql0.default/Mail/Local Folders},where you need to adapt ''uk41lql0.default'' to your own installation). #Launch Thunderbird to check that all your mail have been correctly imported. == Importing Evolution Contacts == #Open your address book in Evolution, right-click on it and choose: '''Save as vcard...''' to export it into vCard file format. #Import this file into Thunderbird: #* In Thunderbird 3 and 3.1, you need to install the [http://nic-nac-project.de/~kaosmos/morecols-en.html MoreFunctionForAddressBook] extension in order to be able to import vCard file. Once this is done, open the Address book window, right click on the entry area and select Import vCard/vcf. Select the .vcf file that you have just saved. #* In Thunderbird 5 or above, open the {menu Tools > Import...} menu, select '''Address Books''' and then '''vCard file ( *.vcf)''' and select your contact file. {/for} = Switching from Web-based Email Applications to Thunderbird = If you are using a web-based application provided by your Internet Service Provider (ISP) to access your email, you probably only need to configure your account information to switch to Thunderbird. See [[Configure an Account]] for instructions. Also, see [[ISP Configuration Settings]] for instructions on specific ISPs. Once you have configured your account in Thunderbird, you should be able to access all your messages (both incoming and sent). However, your address book (contacts), mail filters and other settings will not be automatically transferred to Thunderbird. Some web-base email applications allow you to export contacts in text or comma-separated formats. Check your ISP's documentation for more information. To import contacts into Thunderbird, select {menu Tools > Import…} and follow the instructions on the screen. =See Also= * [http://en.flossmanuals.net/thunderbird/ch014_account-set-up/ Account Setup chapter] in the Thunderbird FLOSS manual * [http://en.flossmanuals.net/thunderbird/migrating/ Migrate to Thunderbird chapter] in the Thunderbird FLOSS manual

Back to History