This forum is a discussion about improving the "Secure Website Certificate" article. If you'd like to participate, please register.

If you need help with Firefox, please ask a question.

Update needed for fx44 and above

  • 1 Replies
  • Last reply by Lan
  1. AliceWyman 4913 posts
    Report Abuse

    We should link to What does "Your connection is not secure" mean? for fx44 and above.

    We should link to [[What does "Your connection is not secure" mean?]] for fx44 and above.
  2. Lan 142 posts
    Report Abuse

    I updated the article.

    I updated the article.