Reset Firefox preferences to troubleshoot and fix problems

Resetting preferences (zoom, tabs, privacy, network, encryption, updates, where to save file downloads, etc.) is one of many procedures that can be helpful in troubleshooting Firefox problems. We'll explain two ways to do this.

Solution 1: Refresh Firefox

Note: When using the refresh feature, your bookmarks, browsing history, open tabs, windows, passwords, cookies and web form auto-fill information will be saved. However, your extensions and themes will be removed and your preferences will be reset.When using the reset feature, your bookmarks, browsing history, open tabs, windows, passwords, cookies and web form auto-fill information will be saved. However, your extensions and themes will be removed and your preferences will be reset.When using the reset feature, your bookmarks, browsing history, passwords, cookies and web form auto-fill information will be saved. However, your extensions and themes will be removed; open tabs, windows and tab groups will not be saved; and your preferences will be reset. Learn more.
  1. Click this Refresh Firefox button directly, if you are viewing this page in Firefox.
    This won't work if you are using a different browser or on a mobile device.
  2. To continue, click Refresh Firefox in the confirmation window that opens.
  3. Firefox will close to refresh itself. When finished, a window will list your imported information. Click Finish and Firefox will open.

Note: There's also a Refresh Firefox button in the Firefox Safe Mode window, if you can't start Firefox normally.

Solution 2: Delete Firefox preference files

  1. At the top of the Firefox window, click on the Firefox button, go over to the Help menuOn the menu bar, click on the Help menuAt the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

  2. Under the Application Basics section, click on Show FolderShow in FinderOpen Directory. A window with your profile filesfolder will open.
  3. Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.
  4. At the top of the Firefox window, click on the Firefox button and then select ExitAt the top of the Firefox window, click on the File menu and then select ExitOn the menu bar, click on the Firefox menu and select Quit FirefoxAt the top of the Firefox window, click on the File menu and select Quit.

    Click the menu button New Fx Menu and then click ExitQuit Close 29 .

  5. Locate and delete the file prefs.js (or rename it, for example, to prefs.jsOLD, to keep the old file as a backup). If you find more than one, a prefs.js.moztmp file or a user.js file, delete (or rename) these as well.
  6. You can close the profile folder and open Firefox now.

Was this article helpful? Please wait...

These fine people helped write this article: AliceWyman, Chris_Ilias, djst, Tonnes, Jan., Verdi, Swarnava, upwinxp. You can help too - find out how.