This forum is a discussion about improving the "Flash Plugin - Keep it up to date and troubleshoot problems" article. If you'd like to participate, please register.

If you need help with Firefox, please ask a question.

Playing Flash videos makes Firefox hang

  • 2 Replies
  • Last reply by AliceWyman
  1. AliceWyman 5146 posts
    Report Abuse

    For the record, the latest version of Flash is still causing the current version of Firefox to hang, as reported here:

    http://forums.adobe.com/message/5808165 Firefox 25 on Windows 7: Flash 11.9.900.117 freezes Firefox

    Note: On Windows, you can also disable hardware acceleration by adding the line DisableHardwareAcceleration=1 to the Flash "mms.cfg" file, as suggested in the above thread. The mms.cfg file is located here:

    (Windows 32bit) C:\Windows\System32\Macromed\Flash
    (Windows 64bit) C:\Windows\SysWOW64\Macromed\Flash
    For the record, the latest version of Flash is still causing the current version of Firefox to hang, as reported here: http://forums.adobe.com/message/5808165 Firefox 25 on Windows 7: Flash 11.9.900.117 freezes Firefox Note: On Windows, you can also disable hardware acceleration by adding the line '''DisableHardwareAcceleration=1''' to the Flash "mms.cfg" file, as suggested in the above thread. The mms.cfg file is located here: : (Windows 32bit) <tt>C:\Windows\System32\Macromed\Flash</tt> : (Windows 64bit) <tt>C:\Windows\SysWOW64\Macromed\Flash</tt>
  2. AliceWyman 5146 posts
    Report Abuse

    I made an edit to the section on disabling HW acceleration to use the same Adobe Help page as the Adobe Flash plugin has crashed - Prevent it from happening again article uses: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

    I also added a missing {/for} that I left off my previous revision.

    I made an edit to the section on disabling HW acceleration to use the same Adobe Help page as the [[Adobe Flash plugin has crashed - Prevent it from happening again]] article uses: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues I also added a missing {/for} that I left off my previous revision.
  3. AliceWyman 5146 posts
    Report Abuse

    I added "Disable protected mode in Flash" (for Windows Vista and above) based on this post by jscher2000 dated 6/23/13 in /questions/962798 Flash hangs Firefox (eventually get script continue/stop dialog)

    After some overdue Windows updates, I got hit with severe hangs when opening any page with Flash media. The window frame controls (e.g., minimize) still worked, but everything inside was inaccessible for minutes at a time. Then I would get a dialog indicating that a script was running slowly and had the opportunity to stop or continue.

    I had already disabled hardware graphics acceleration in Firefox and Flash, so the logical next step was to disable the Flash Player's protected mode. That is described in this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

    It worked.
    I added "Disable protected mode in Flash" (for Windows Vista and above) based on this post by jscher2000 dated 6/23/13 in [/questions/962798] ''Flash hangs Firefox (eventually get script continue/stop dialog)'' <blockquote> After some overdue Windows updates, I got hit with severe hangs when opening any page with Flash media. The window frame controls (e.g., minimize) still worked, but everything inside was inaccessible for minutes at a time. Then I would get a dialog indicating that a script was running slowly and had the opportunity to stop or continue. <br><br> I had already disabled hardware graphics acceleration in Firefox and Flash, so the logical next step was to disable the Flash Player's protected mode. That is described in this support article from Adobe under the heading "Last Resort": [http://forums.adobe.com/message/4468493#TemporaryWorkaround Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?] <br><br> It worked. </blockquote>
    Modified by AliceWyman on