Install an older version of Firefox

Revision Information
  • Revision id: 15227
  • Created:
  • Creator: scoobidiver
  • Comment: Firefox 3.6 is the previous version
  • Reviewed: Yes
  • Reviewed:
  • Reviewed by: AliceWyman
  • Is approved? Yes
  • Is current revision? No
  • Ready for localization: No
Revision Source
Revision Content

The template "Only in Fx4" does not exist or has no approved revision. This article describes how to install a previous version of Firefox, a process also known as "downgrading". For instructions on how to install a newer version, see Update Firefox to the latest release.


Installing a previous version doesn't fix most problems

Problems with an update are generally not caused by the new version of Firefox, but rather the update process. Installing a previous version will not help in most cases. Instead, see:

Other problems can be solved by creating a new profile.


I still want to downgrade — where can I get the previous version?

Starting with the release of Firefox 5, the previous version of Firefox (Firefox 4 in this case) (Firefox 5 in this case) will no longer be maintained with security updates. Because of this, you should install Firefox 3.6 by downloading and running its installer from this page.

Warning: Firefox 3.6 will only be maintained with security and stability updates for a short amount of time.