How to Install and Use another Language in the Dictionary on Thunderbird

If you send messages in more than one language, you can install additional spell-checking dictionaries to Thunderbird. After installing a dictionary, it is easy to switch from one language to another.

Language dictionaries are available as Thunderbird add-ons. See the Thunderbird add-ons - frequently asked questions for more information.

Install a new language dictionary

  1. At the top of the Thunderbird window, click the Tools menu (Alt + T) and select Options…OptionsIn the menu bar, click the Thunderbird menu and select PreferencesAt the top of the Thunderbird window, click the Edit menu and select Preferences, or click the Application menu button New Fx Menu and choose Options…OptionsPreferences.
  2. Select the Composition panel, followed by the Spelling tab.
  3. Click Download More Dictionaries, then click OK to close the dialog.
  4. In the opened tab, scroll through the alphabetic list of dictionaries to find the one you want.
  5. Click Download Dictionary next to the language of your choice.
  6. In the opened page of the selected dictionary, click the green Add to Thunderbird button.
  7. In the Software Installation window, click Install Now.
  8. Restart Thunderbird if prompted.

That's it! Your new dictionary is installed. To uninstall it, open the Add-ons Manager, find the dictionary on the Dictionaries or Extensions panel and click the Remove button next to it.

Switch between different languages

Select a language for one particular message

Right-clickHold down the Ctrl key while you click in the message you are writing and select a language in the Languages menu.

TB switch dictionaries

Set the default language for all messages

  1. At the top of the Thunderbird window, click the Tools menu (Alt + T) and select Options…OptionsIn the menu bar, click the Thunderbird menu and select PreferencesAt the top of the Thunderbird window, click the Edit menu and select Preferences, or click the Application menu button New Fx Menu and choose Options…OptionsPreferences.
  2. Select the Composition panel, followed by the Spelling tab.
  3. Select the desired language from the drop-down list.
  4. Click OK to close the dialog.

Dictionary popup menu

Was this article helpful? Please wait...

These fine people helped write this article: Tonnes, Swarnava, ideato, MattAuSupport, user669794, upwinxp, jsavage, Artist. You can help too - find out how.