This forum is a discussion about improving the "How to download and install Firefox on Mac" article. If you'd like to participate, please register.

If you need help with Firefox, please ask a question.

[Sept 2016] Update warning note based on new system requirements for Firefox 49

  • 4 Replies
  • Last reply by AliceWyman
  1. AliceWyman 4782 posts
    Report Abuse

    Related bug: Bug 1255518 - Firefox download buttons: drop support for OS X 10.6-10.8 in August 2016

    I have a revision pending to update the warning note for old Mac OS X systems and included a link to the article Firefox support has ended for Mac OS X 10.6, 10.7 and 10.8, which says, The Firefox version 48 release in August 2016 will be the last Firefox version to receive new feature or security updates on OS X systems that are no longer supported by Apple: OS X 10.6, 10.7 and 10.8. Starting with the Firefox version 49 release in September 2016, Firefox is no longer supported on OS X systems below 10.9.

    The warning note links to the System Requirements page. However, https://www.mozilla.org/en-US/firefox/48.0/system-requirements/ shows OS X 10.9 as the minimum version for Firefox 48. Is the requirements page wrong or is the linked article wrong? See https://support.mozilla.org/en-US/kb/firefox-osx/discuss/6613 for the background.

    Related bug: [https://bugzilla.mozilla.org/show_bug.cgi?id=1255518 Bug 1255518] - Firefox download buttons: drop support for OS X 10.6-10.8 in August 2016 I have a revision pending to update the warning note for old Mac OS X systems and included a link to the article [[Firefox support has ended for Mac OS X 10.6, 10.7 and 10.8]], which says, ''The Firefox version 48 release in August 2016 will be the last Firefox version to receive new feature or security updates on OS X systems that are no longer supported by Apple: OS X 10.6, 10.7 and 10.8. Starting with the Firefox version 49 release in September 2016, Firefox is no longer supported on OS X systems below 10.9.'' The warning note links to the [https://www.mozilla.org/firefox/system-requirements System Requirements] page. However, https://www.mozilla.org/en-US/firefox/48.0/system-requirements/ shows OS X 10.9 as the minimum version for Firefox 48. Is the requirements page wrong or is the linked article wrong? See https://support.mozilla.org/en-US/kb/firefox-osx/discuss/6613 for the background.
  2. ideato 567 posts
    Report Abuse

    AliceWyman said

    Related bug: Bug 1255518 - Firefox download buttons: drop support for OS X 10.6-10.8 in August 2016 I have a revision pending to update the warning note for old Mac OS X systems and included a link to the article Firefox support has ended for Mac OS X 10.6, 10.7 and 10.8, which says, The Firefox version 48 release in August 2016 will be the last Firefox version to receive new feature or security updates on OS X systems that are no longer supported by Apple: OS X 10.6, 10.7 and 10.8. Starting with the Firefox version 49 release in September 2016, Firefox is no longer supported on OS X systems below 10.9. The warning note links to the System Requirements page. However, https://www.mozilla.org/en-US/firefox/48.0/system-requirements/ shows OS X 10.9 as the minimum version for Firefox 48. Is the requirements page wrong or is the linked article wrong? See https://support.mozilla.org/en-US/kb/firefox-osx/discuss/6613 for the background.

    Hi Alice, probably the requirements page is wrong, see James reply.

    thanks

    ''AliceWyman [[#post-14210|said]]'' <blockquote> Related bug: [https://bugzilla.mozilla.org/show_bug.cgi?id=1255518 Bug 1255518] - Firefox download buttons: drop support for OS X 10.6-10.8 in August 2016 I have a revision pending to update the warning note for old Mac OS X systems and included a link to the article [[Firefox support has ended for Mac OS X 10.6, 10.7 and 10.8]], which says, ''The Firefox version 48 release in August 2016 will be the last Firefox version to receive new feature or security updates on OS X systems that are no longer supported by Apple: OS X 10.6, 10.7 and 10.8. Starting with the Firefox version 49 release in September 2016, Firefox is no longer supported on OS X systems below 10.9.'' The warning note links to the [https://www.mozilla.org/firefox/system-requirements System Requirements] page. However, https://www.mozilla.org/en-US/firefox/48.0/system-requirements/ shows OS X 10.9 as the minimum version for Firefox 48. Is the requirements page wrong or is the linked article wrong? See https://support.mozilla.org/en-US/kb/firefox-osx/discuss/6613 for the background. </blockquote> Hi Alice, probably the requirements page is wrong, see [https://support.mozilla.org/en-US/questions/1133642#answer-903657 James reply]. thanks
  3. AliceWyman 4782 posts
    Report Abuse

    ideato said

    Hi Alice, probably the requirements page is wrong, see James reply.

    Yes, the Firefox 48 system requirements page is wrong (hopefully it will be fixed!) . I just updated to Firefox 48 on my husband's iMac running OS X 10.6.8. I was also able to download the "Firefox 48.0.dmg" installer and installed it in a different location as a test. It ran fine.

    ''ideato [[#post-14211|said]]'' <blockquote> Hi Alice, probably the requirements page is wrong, see [https://support.mozilla.org/en-US/questions/1133642#answer-903657 James reply]. </blockquote> Yes, the [https://www.mozilla.org/en-US/firefox/48.0/system-requirements/ Firefox 48 system requirements] page is wrong (hopefully it will be fixed!) . I just updated to Firefox 48 on my husband's iMac running OS X 10.6.8. I was also able to download the "Firefox 48.0.dmg" installer and installed it in a different location as a test. It ran fine.
  4. AliceWyman 4782 posts
    Report Abuse

    I'll defer my pending revision and I'll add a "Needs change" entry to resubmit the August 5, 2016 revision to update the warning note with the System Requirements link in September 2016.

    I'll defer my pending revision and I'll add a "Needs change" entry to resubmit the August 5, 2016 revision to update the warning note with the System Requirements link in September 2016.
  5. AliceWyman 4782 posts
    Report Abuse

    I made another revision to update the warning note and specifically mentioned Firefox 49.

    I made another revision to update the warning note and specifically mentioned Firefox 49.