Firefox support has ended for Mac OS X 10.6, 10.7 and 10.8

Revision Information
  • Revision id: 151515
  • Created:
  • Creator: AliceWyman
  • Comment: Firefox 45 ESR is no longer an option; updated Mac OS upgrade info
  • Reviewed: Yes
  • Reviewed:
  • Reviewed by: AliceWyman
  • Is approved? Yes
  • Is current revision? No
  • Ready for localization: Yes
  • Readied for localization:
  • Readied for localization by: AliceWyman
Revision Source
Revision Content
This article applies to Mac users only.

Starting with Firefox version 49, Firefox requires Mac OS X 10.9 (Mavericks) or higher. Visit this Apple Support page to find your Mac OS version.

If you're using an outdated version of Firefox on Mac OS X 10.8 (Mountain Lion) or earlier, the only way you can update Firefox to a secure version is to upgrade your Mac to a version that Apple supports. Visit this Apple Support page to learn more about upgrading your Mac.

Note: If you have Mac OS X 10.7 (Lion) or 10.6 (Snow Leopard) you will need to download Mac OS X El Capitan before you can upgrade to the latest Mac OS.

While insecure versions of Firefox will continue to work on OS X 10.8 and earlier, using an up-to-date version of Firefox on a supported version of Mac OS provide you with the best and safest user experience.