Add-ons that cause stability or security issues are put on a blocklist

Revision Information
  • Revision id: 10411
  • Created:
  • Creator: scoobidiver
  • Comment: incompatible add-on adding, automatic add-ons updates for fx4, difference of behavior between fx35 and fx4, summary and keywords adding.
  • Reviewed: Yes
  • Reviewed:
  • Reviewed by: scoobidiver
  • Is approved? No
  • Is current revision? No
  • Ready for localization: No
Revision Source
Revision Content

Add-ons (extensions, themes, and plugins) that are known to cause stability or security issues with Firefox or are incompatible are put on a "blocklist."

What does the blocklist do?

Disables unsafe add-ons

Firefox will block the unsafe add-on from loading and present you at startup with the following message:

Firefox has determined that the following add-ons are known to cause stability or security problems


Add-ons Blocklist Mac1

To prevent these add-ons from running, click Restart Firefox.

Blocks unsafe add-ons from being installed

When you try to install an unsafe add-on that is on the blocklist, Firefox will block the installation and display the message:

The add-on name has a high risk of causing stability or security problems and can't be installed.

Disables incompatible add-ons

Firefox will block the incompatible add-on from loading. In the Add-ons window,In the Add-ons manager tab, below the add-on, you've got the following message:

The add-on name is incompatible with your Firefox version.

Blocks incompatible add-ons from being installed

In the Mozilla add-ons website, incompatible add-ons show up with a Add to Firefox white button. If you click on the button, you will be prompted with the following message:

This add-on has not been updated to work with your version of Firefox.

You can choose to ignore this message and click on the Install Anyway button. When the download is complete, you will be prompted with the following message:

The add-on name could not be installed because it is not compatible with your Firefox version.


Steps to take

If the installed add-on is disabled

Extension or theme

  1. At the top of the Firefox window, click on the Firefox button (Tools menu in Windows XP), and then click Add-onsOn the menu bar, click on the Tools menu, and then click Add-onsAt the top of the Firefox window, click on the Tools menu, and then click Add-ons. The Add-ons Manager tab will open.
  2. On the "Tools for all add-ons" menu, make sure that the Update Add-ons Automatically menu is checked.
  1. At the top of the Firefox window, click on the Tools menu, and select Add-onsOn the menu bar, click on the Tools menu, and select Add-onsAt the top of the Firefox window, click on the Tools menu, and select Add-ons. The Add-ons window will open.
  2. Select the Extensions or Appearance panel depending on the kind of add-on.
  3. Then click Find Updates. If Firefox finds an update, you will be prompted to install it and restart Firefox.

Plugin

To check if any of your installed plugins are out of date, visit Mozilla's Plugin Check & Updates page.

Note: If there are no updates available, you may need to contact the developer of the add-on that was blocked.

Installation blocked

If you were blocked from installing an add-on, check to see if there is an updated version of the add-on you were trying to install.

Note: If there is not an updated version to install, you may need to contact the developer of the add-on that was blocked.


What unsafe add-ons are on the blocklist?

See list of blocklisted unsafe add-ons.