Αναζήτηση στην υποστήριξη

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

Firefox is unbearably slow after updating to version 27

  • 81 απαντήσεις
  • 606 έχουν αυτό το πρόβλημα
  • 41117 προβολές
  • Τελευταία απάντηση από petef

more options

After updating to Firefox 27 all webpages take a few dozen seconds to several minutes to load. When loading a webpage Firefox's status displays "connecting" and the CPU gets maxed out with 95 to 100% of its cycles taking by Firefox.

The computer is older so it is a little slow but Internet Explorer 8 has no trouble opening the webpages and neither do other computers on the LAN so it is not a network issue. I have tried restarting Firefox, disabling add-ons, deleting add-ons, disabling hardware acceleration, restarting the computer, and reinstalling Firefox after wiping every trace of it and its user data from the hard drive and registry.

CPU: AMD Athlon 2800+ 2.08GHz RAM: 1GB OS: Windows XP Home Edition Service Pack 3 32bit


Comments by a forum moderator.
(Modified April 30, 2014 12:11:58 PM BST by John99 ) ~J99
Rather a long thread so I will add some comments here where easily seen.

 Modified June 18, 2014 6:08:41 AM PDT by John99

Τροποποιήθηκε στις από το χρήστη John99

Όλες οι απαντήσεις (20)

more options

A whole day wasted with re-installs, modifying start-ups, safe mode, restores etc. on a very old XP machine which just sat with arrow spinning on half the sites. Given up then found this about cairo. Sorted in a couple of clicks and now all back to perfect. Obviously something very wrong in 27.

Thank you very much Jigebren for this!!

more options

Did anyone try disabling Azure instead of editing the "backend" preference?

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste gfx and pause while the list is filtered

(3) Double-click the gfx.content.azure.enabled preference to switch it from true to false.

more options

@jscher2000 - Just tried to disable via gfx.content.azure.enabled and it works too, indeed.

Would you actually recommend disabling Azure when only the backend setting is the issue?

more options

Hi jigebren, I think the back ends are listed in the order from most preferred to least preferred. If for one reason or another Direct2D is not available, then Cairo is used. If you delete Cairo in that case, then Azure can't run, so I think it works out the same. But from the perspective of understanding what's going on in Firefox, it may be easier to remember what you changed and undo the change if you switch enabled between true and false.

more options

Note that support for gfx.content.azure.enabled is removed in Firefox 28 and later (Bug 934533).

more options

@jigebren OMG, you did it!! Mozilla devs should ditch this Cairo Crap it makes browsers unbearably slooOOooOoOoOoowwWWwww

Wait... wait.. SllsooooOOooOOOoooWW.

Switching back to lovely Direct2D did a fantastic job. Good work and thank you, jigebren!

more options

@jscher2000 - Out of curiosity, do you know what is used when "AzureContentBackend" is "none"? If it's neither Direct2D nor cairo, what does work for us then?

@cor-el - Thanks for the info, and that doesn't sound good. I just tried and though gfx.content.azure.enabled is actually no more in v28, gfx.content.azure.backends was still here. But apparently it no longer has any effect: in about:support, AzureContentBackend still displays cairo even with the workaround I'm using now.

I can not understand why they removed support for a property that can be used as a workaround for some issues before those issues are actually fixed up (if this property crashes Fx just don't use it then, disabling it is overkill - this is an advanced settings anyway).

Seems like we'll soon have to disable Fx update once again...

more options

I went looking around about:config and typed in gfx and noticed a BOLD faced line that I know I didn't change. I don't recall the full line as it seems to have disappeared after resetting the entry. I do know that i typed "gfx" there was a bold faced line and it said "LastUsed" something, and it ended with "_idx" and had a value set of "0" and after right clicking that and selecting "reset" it fixed the slow downs i was having with FIrefox 27.0.1 with Flash player 12.0.0.70 and it may fix it for other version combinations. It's the only thing I changed and I haven't had any issues since.

Let me know if this works for you guys.

more options

Yes version 26 worked fine, 27 sucks terribly. I literally have to load, reload, reload EVERY single site I visit, even if its a common one like Facebook where I go to it a lot. SO TIRED of this. I'm not as PC smart as most here, so I'm trying to figure out how to roll back to version 26 and still keep all my bookmarks. Not even sure if it can be done.

This is depressing. I usually LOVE FF but not so much these days.

more options

Hi Halofromsue, this article has a link to Firefox 26 if you visit using Firefox 27: Install an older version of Firefox. You may want to start a new question if problems continue.

more options

jigebren Thank you, worked a treat.

Looking at other posts it seems this problem is being experienced by many people since v.27.

Is this likely to be sorted for v.28???? Else may go back to v.26.

more options

You know, this wouldn't be nearly as annoying if when I searched for a solution, half the results were press releases about how much "faster" 27 supposedly is, even though anyone with half a brain could tell that its slower. Way slower.

I still haven't decided if they're lying, or honestly don't know. Neither really inspires confidence.

Τροποποιήθηκε στις από το χρήστη BrokenEye

more options

@jigebren@ What are AzureContentBackend and cario, anyway? I don't want to disable something without knowing what it does.

more options

An update from me:

  1. On my work PC, double-clicking the gfx.content.azure.enabled preference to switch it from true to false solved the slow down problem.
  2. On my home PC, this trick didn't work and Firefox was still painfully slow and hogged the CPU. However, I came across this post: SiteAdvisor and Firefox. Following the advice to disable the McAfee SiteAdvisor 3.6.5 add-on worked a treat, so I am up to speed now on my home PC as well. Apparently version 3.6.6 of SiteAdvisor is released next week – I'll see if that help things and report back.
more options

Hi BrokenEye, are you also running Windows XP?

Azure is a technology to speed up page layout. It was introduced into Firefox a couple years ago but is constantly tweaked and refined. Apparently something changed in Firefox 27 which reduces performance on some systems. Hopefully that will be discovered and fixed. Meanwhile, you can disable Azure either by toggling the enabled preference from true to false, or changing the backend property to something which isn't available on your system, in which case Firefox won't use be able to use Azure. I don't know what side effects this would have on page layout accuracy or speed; I think you'll have to assess this on the sites important to you to see whether it is the best trade-off for you.

more options

@BrokenEye@ No, Windows 7.

I'll try that, thanks.

more options

Okay, I pulled up about:support but the value of AzureContentBackend is "direct2d", not "cairo". And I don't know how to change the values. There aren't any text fields or anything and the only buttons are "Copy raw data to clipboard", "Copy text to clipboard", "Show Update History", "Show Folder" and "Restart Firefox"

more options

Hi BrokenEye, about:support is an informational page (also accessed using Help > Troubleshooting Information).

If you want to change the settings, you want the about:config preferences editor.

more options

@jscher2000@ Okay, I found gfx.content.azure.backends in about:config. Is that the same as AzureContentBackend? The value is "direct2d,cairo". I want it to just say "direct2d", right?

I just want to be clear on this before making any changes.

more options

Hi BrokenEye, if you want to prevent Firefox from using Azure with the Cairo "back end" then yes, you just want "direct2d". You might need to exit and restart Firefox to see a difference. (Or if there is no difference, this is not your problem.)

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5