Search Support

Translation of Chinese characters, that for some unexplained reason appear on my Firefox browser

  • 3 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 35 προβολές
  • Τελευταία απάντηση από cor-el

more options

Have been to China, but now I'm in Australia. I downloaded Firefox in Australia, not China. However some of my Firefox buttons are in Chinese?! How can I stop this. Also does Firefox have a 'translate' button. If so where is it hidden.

Yours truly Ian Wickham

All Replies (3)

more options

As you work down from the top of the Firefox UI through the menu (either the orange Firefox button compact menu, or the full menu bar), Navigation Toolbar, Bookmarks Toolbar, are there any unexpected Chinese-character buttons on those? Or does it start when you get to the web page?

Some websites may have saved your location while you were traveling. Try clearing your Firefox cache and deleting your saved cookies for the problem sites.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

more options

Firefox doesn't have built-in translation like some competing browsers. However, there are some add-ons you could research to add that. (I haven't tried any of them myself.)

more options

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.