Αναζήτηση υποστήριξης

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FIREFOX 19.0.2 NOT RESTORING TABS FROM PREVIOUS SESSION

  • 38 απαντήσεις
  • 25 έχουν αυτό το πρόβλημα
  • 12501 προβολές
  • Τελευταία απάντηση από 987666

more options

Just upgraded to 19.0.2.

Have Options set to "show my windows and tabs from last time" and is suddenly not restoring if I exit using File and then Exit command. It randomly saves a prior tab from the last time I rebooted only. It is, however, acting on the startup commands. For example, when I select "show blank page" or "show home page", it works. As soon as I select "show my windows and tabs from last time", it goes back to tab prior to the reboot and not the last tabs that I had prior to closing the last session.

When I exit using the "X" at the top right hand corner, however, no problem. My tabs from the previous session automatically re-appear but ONLY if I have "Show All Bookmarks" activated. If I exit that, then once again, that tab prior to the reboot reappears.

I tried uninstalling and reinstalling FF (keeping my prior settings) and it did nothing. I have the history under the Privacy tab set to "remember history"

On a side note, I tried my other PC with the same version of FF, and it does not have this problem

Όλες οι απαντήσεις (20)

more options

You can check for problems with the sessionstore.js and sessionstore.bak files in the Firefox Profile Folder that store session data.

Delete the sessionstore.js file and possible sessionstore-##.js files with a number and sessionstore.bak in the Firefox Profile Folder.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost, so you will have to create them again (make a note or bookmark them).

more options

I found my answer to this problem here: https://support.mozilla.org/en-US/questions/937360

User "ovalerio" suggested checking preferences > privacy > history and making sure the box "clear history when Firefox closes" is *not* checked (you may have to select "use custom settings" in the dropdown to reveal this setting.

I have no idea why this box ended up checked, as I certainly did not check it, but whatever. One of those Firefox things, I suppose. Unchecking that box, though, solved my problem, as well as the problem I was having with lengthy shutdown times and, obviously, Firefox not recording my history. This browser really gets to me sometimes.

more options

Berrex - there is no "Preferences" under the "Edit" menu. Like I said, I'm using 19.0.2. Please advise.

more options

Sorry mcs2013, it's called Preferences if you're using the Linux version like I am. If you're using Windows, it will be Options, found by clicking the orange Firefox button in the top left (or, if you don't see an orange Firefox button, it will be under Tools > Options). If you use a Mac, it will be Firefox > Preferences.

more options

In case you are using "Clear history when Firefox closes":

  • do not clear Browsing History

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

more options

cor-el - there is no History: [X] Clear history when Firefox closes > Settings under the "Privacy" label.

Please advise!

more options

To see all history choices/settings, use:

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
more options

Tried this and still goes back to the page saved several session back. Also, when I selected "Use custom settings for history", it would not save this selection and instead went back to "Remember history".

I attempted your previous suggestion and went into "Troubleshooting Information" and there is no "Profile Directory".

I am totally lost.

Please advise.

more options

Tried this and still goes back to the page saved several session back. Also, when I selected "Use custom settings for history", it would not save this selection and instead went back to "Remember history".

I attempted your previous suggestion and went into "Troubleshooting Information" and there is no "Profile Directory".

I am totally lost.

Please advise.

more options

Keeps going back to "Remember history" no matter what. Help!

more options

hello mcs2013, see :Preferences not saved

I attempted your previous suggestion and went into "Troubleshooting Information" and there is no "Profile Directory".

see the screenshot, click the Show folder to open profile folder

thank you

more options

I tried clicking "Show Folder" and nothing opened. Perhaps this is part of the problem?

more options

see : Corrupt or damaged prefs.js file

thanks again

more options

Since I have a lot of saved data (bookmarks, passwords, etc.) I followed the instructions and saved a copy of the profile folder elsewhere.

The instruction then say " If you have a current profile backup, replace the prefs.js file in your profile folder with the backup copy."

This does not specify which file; I have two prefs.js file in the profile folder, prefs.js.bak and prefs.js.new. Which one do I replace with the backup copy???

more options

For testing it is best to remove all prefs.js files and not restore a backup.

Note that Windows may be hiding the .js file extension and only show you a prefs file.

Did you try to remove the sessionstore.js file?


The "Use custom settings for history" choice allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings.
Firefox shows the "Use custom settings for history" selection as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made.
If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History".

more options

I deleted the following files: all prefs.js files & all sessionstore.js files. Doing that cleared that last session, but now it only recognizes the Home Page selection upon refresh (or closing and opening). The "Show my windows and tabs from last time" selection is still not restoring my tabs and seems completely non-functional. What else?

Τροποποιήθηκε στις από το χρήστη mcs2013

more options

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

more options

OK here is what I did, and it worked:

1. Start FF 19 x in safe mode. Under "Help" - select: "restart with addons disabled." It will confirm that you want to start FF in safe mode. LISTEN: >> DO NOT << click "reset FF" -- OR -- it will set FF as it was when you first downloaded it - and you may lose all your settings! Make sure that you just start it in safe mode!

2. Then FF will open in safe mode, with all addons temporarily disabled. You should now see all the missing tabs.

3. Next, close FF.

4. Restart FF normally. Tabs are back up. I tested it 7 times by closing and restarting, and it fixed whatever the problem was! BTW your addons that were previously enabled will resume automatically. Although I appreciate the other suggestions, FYI: my box: "clear history when Firefox closes" was NOT checked. I did not delete sessionstore js files either.

Often, this simple start in safe mode/close/restart procedure remedies a lot of strange problems.

Hope you have the same fix. JM

Τροποποιήθηκε στις από το χρήστη pashadad

more options

I followed "Create Profile" and nothing happened. I don't see the new profile folder. Totally lost/don't understand. I need to step-by-step rather than trying to figure out where to look.

What about just doing a complete reinstall using backed up profile, this is ridiculous?

more options

@mcs2013 - did you try my safe mode procedure?

  1. 1
  2. 2