Αναζήτηση υποστήριξης

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 17.0 doesn't relized installation of adobe flash player 10.3 or 11.5

  • 15 απαντήσεις
  • 34 έχουν αυτό το πρόβλημα
  • 3355 προβολές
  • Τελευταία απάντηση από equitube

more options

I removed and installed Adobe Flash Player (AFP) a lot of times without error but, Firefox (FF) doesn't realize AFP.

Επιλεγμένη λύση

This problem drove me nuts. I tried about everything. Finally creating a new profile using the profile manager, https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?esab=a&s=creating+a+new+profile&r=0&as=s

I used nothing from the old profile, and deleted it although I backed it up first. Interestingly the new profile had some problems with a hijacked home page. Finally booting firefox in safe mode and disabling all add ons worked.

Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (15)

more options

Note that Firefox is a 32 bit application, so you need to install the 32 bit Flash version if the Flash installer didn't do this automatically.

Did you try to run the Flash installer as Administrator (right-click: run as Administrator)?

You can find the latest Flash player versions for Firefox on this page.

Do you see the Flash player file (NPSWF32_11_X_XXX_XXX.dll) in this folder?

  • C:\Windows\SysWOW64\Macromed\Flash\

You can also check if the Flash installer has created the registry key that allows Firefox to locate the plugin via a registry scan.

  • HKLM\SOFTWARE\Wow6432Node\MozillaPlugins\plugin-id
more options

Thanks for helping but, None of them is working for me.

more options

Did you check for the presence of the Flash plugin in the C:\Windows\SysWOW64\Macromed\Flash\ folder?

more options

That would indicate that the Flash plugin is installed.

Do you also have the registry key that allows Firefox to find the plugin?

  • HKLM\Software\Wow6432Node\MozillaPlugins\<plugin-id>
more options

As I told you. I tried everything you said in first response.

more options

Yes,that is correct.

Try to delete the pluginreg.dat file in the Firefox Profile Folder and maybe addons.sqlite as well to reset the plugin registry databases.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder
more options

I exit from ff. I delete pluginreg.dat. I restarted it and ff create another one, but AFP still doesn't work. :(

more options

Does Firefox find all other plugins that show in the registry screenshot?

  • HKLM\Software\Wow6432Node\MozillaPlugins\
more options

No, They are not matching as you can see.

more options

You aren't using by any chance a 64 bit Firefox version?

more options

If I know correctly, there is no 64 bit firefox in mozilla's website, isn't it?

Should I install from following website?

http://www.firefox64bit.com/

more options

I made a back-up by mozbackup 1.5. I didn't restore general settings. It works now.

more options

I have had suffering from this problem for more than 1 month but finally I solved:

To got sorting for this problem you can do the follwing thing:

1. Copy all files from this directory: C:\Windows\SysWOW64\Macromed\Flash\

2. Paste these files into the Plugin file of the latest version of firefox that you have download.

3. Then it will work.

But still I have one question for FireFox Company: why they did not include Flash Player in the FireFox Package when we download similar to Google Chrome. For example, Google Chrome include Flash Player and other things with its download Package?

more options

Επιλεγμένη λύση

This problem drove me nuts. I tried about everything. Finally creating a new profile using the profile manager, https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?esab=a&s=creating+a+new+profile&r=0&as=s

I used nothing from the old profile, and deleted it although I backed it up first. Interestingly the new profile had some problems with a hijacked home page. Finally booting firefox in safe mode and disabling all add ons worked.