Αναζήτηση υποστήριξης

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

Remove Plugin Container

  • 12 απαντήσεις
  • 89 έχουν αυτό το πρόβλημα
  • 30764 προβολές
  • Τελευταία απάντηση από Ad_Hoc

more options

I've upgraded to the latest firefox, and now Plugin Container is back :(

Please help me put it back to just the one "firefox.exe" process that i've had it set to since Version 3.

Επιλεγμένη λύση

Some plugins only work properly via the plugin-container process and not embedded in Firefox, so that is why the plugin-container process is now forced on in some cases and can't be disabled.

See also http://forums.mozillazine.org/viewtopic.php?f=38&t=2503949

Ανάγνωση απάντησης σε πλαίσιο 👍 4

Όλες οι απαντήσεις (12)

more options

You want to disable crash protection, see : Disabling crash protection

see also for info : What is plugin-container


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

more options

It's already set to false, but plugin container is still there and has only appeared since FF14.

more options

There are some follow up bugs in this issue and developers working on this. Sorry for that, i think soon we have the fix.

more options

Firefox will go bankrupt if U continue to insist repeatedly make the same mistakes of 10 versions ago. This Plugin Container is the big one. Is simply impossible to work with the Firefox eating so much CPU. And don't put blame on plugins because other browsers work very well with plugins and do not let the cooler computer crazy all the time and so little the CPU temperature so high all the time.

Or Mozilla radically opens the mind, or Firefox will gonna bye bye. With this Plugin Container return, I gave up. Enough to warm up the computer. I was a fan of Firefox for years, but now I'll stop being stubborn and open my mind. I'm going to Chrome.

more options

Επιλεγμένη λύση

Some plugins only work properly via the plugin-container process and not embedded in Firefox, so that is why the plugin-container process is now forced on in some cases and can't be disabled.

See also http://forums.mozillazine.org/viewtopic.php?f=38&t=2503949

more options

Hi walnor, if you are running Windows Vista/Windows 7 and see an association between Flash media and high memory or CPU usage in Firefox, consider turning off the new protected mode of Flash 11.3. In this support article from Adobe it's under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

more options

To ideato:

The purported solution for "Firefox 4 and above" in your first link does not disable the loading of Plugin Container, which freezes a FF15 with no extensions or plugins in my Win-7 machine (see https://support.mozilla.org/en-US/questions/936149). From this perspective, It is rather laughable responding later "there are some follow up bugs in this issue". Walnor seems right in his/her evaluation of Mozilla's OOPP approach. Chrome's approach may use more memory, but works smoothly. Sigh.

Τροποποιήθηκε στις από το χρήστη Ad_Hoc

more options

Hi Ad_Hoc,

we are talking before one month...!!

you said : ....It is rather laughable responding later "there are some follow up bugs in this issue".

you can see it here: https://support.mozilla.org/en-US/forums/contributors/708513?last=48024#post-47871


thank you

more options

On Windows the plugin-container.exe causes high processor utilisation and poor performance in Firefox and on the machine generally.

To stop it, do this:

Type about:config into the address bar

Type dom.ipc.plugins into the search box

Set the value dom.ipc.plugins.enabled to false

Restart Firefox

more options

Thank you, mwill, but as I already indicated a month ago such rather old solution --which I had of course tried long before posting-- does not solve the freezing of FF14-16 by plugin-container in my Win7 machine.

I solved the problem as I describe in < https://support.mozilla.org/en-US/questions/936149#answer-365854 > : Add a global variable named MOZ_DISABLE_OOP_PLUGINS to the Windows 7 system environment setting it to 1 (i.e., true).  After that, the obnoxious OOPP container contraption ceases to be loaded and no longer freezes FF.  Let see how long this works until another purported OOPP improvement is introduced.

more options

What about for Win XP Home Edition? Will it work for that? I mean when that container kicks in it zaps almost all my CPU's, aside from making my older IBM PC scream like a banshee.

more options

Yes, it will work in XP.  The system's environment, where this variable must be added, is a segment of memory reserved for parameters --in the form of text-string variables whose values can affect running processes-- that has been present in all MS operating systems since DOS 2.0 (the first MS-DOS version written entirely at Microsoft, as prior versions were based on Tim Patterson's QDOS), when they adopted the UNIX concept of environmental variables.

To add the variable: right click on My Computer  > Properties  > Advanced tab > Environment Variables.  Select New in the lower pane (System Variables, which are global) and enter MOZ_DISABLE_OOP_PLUGINS in the name field and 1 in the value field.  Click OK twice to save and exit.  To confirm the variable has been added, run CMD.EXE ; once you are in the DOS box enter SET at the prompt and check that the variable is indeed listed and set to 1.