Αναζήτηση υποστήριξης

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

Firefox 6 rendering problem

  • 8 απαντήσεις
  • 13 έχουν αυτό το πρόβλημα
  • 214 προβολές
  • Τελευταία απάντηση από WoollyWormhead

more options

I am using 64 bit version of Ubuntu 11.04, under Ubuntu Classic, using ATI proprietary driver 11.5. Firefox 6 was installed via a Firefox-stable channel update.

I had absolutely no issue with previous versions of Firefox, until I did an upgrade, and the entire window of Firefox stops rendering properly, as seen in screen cap below.

Basically besides the window control bar on top, everything else seems to be double rendered and one of the render is miss aligning the Y axis.

As I move my mouse around, every interactive objects gets rendered again and rendered incorrectly. Making Firefox largely unusable.

BTW, I have tried start firefox under safe mode using firefox -safe-mode The browser started without addons but rendering issue is still thre.

Am I the only one seeing this? And how do I fix it?

I have posted the same question over at askubuntu.com, and got no resolution, but I did post the image of the rendering issue. Link below: Image of the rendering issue

Τροποποιήθηκε στις από το χρήστη hansioux

Επιλεγμένη λύση

Try to disable hardware acceleration.

  • Edit > Preferences > Advanced > General > Browsing: "Use hardware acceleration when available"

Create a new profile as a test to check if your current profile is causing the problems.

See Basic Troubleshooting: Make a new profile:

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)

See:

Ανάγνωση απάντησης σε πλαίσιο 👍 3

Όλες οι απαντήσεις (8)

more options

Could be a problem with the Ubuntu built version or a problem with the ati driver or maybe even the gtk theme you are using that is not likely so much.

more options

Επιλεγμένη λύση

Try to disable hardware acceleration.

  • Edit > Preferences > Advanced > General > Browsing: "Use hardware acceleration when available"

Create a new profile as a test to check if your current profile is causing the problems.

See Basic Troubleshooting: Make a new profile:

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)

See:

more options

I am using the Ubuntu's default Ambiance theme, as for Firefox's theme, I am using the Default theme that matches the Ambiance theme.

I don't know if Firefox 6 enabled some kind of GPU acceleration. If it did, then some conflict with the ATI driver could be what's going on. But I have no idea what's going on.

more options

i will try both solutions by cor-el when i get the chance. i'll report back.

more options

Ah yes the hardware acceleration can be a issue in some cases.

more options

The disable hardware acceleration helped. pity... there's nothing else i can do to fix the problem and still use hardware acceleration.

this is a workaround, rather than a fix.

more options

I got the same problem with Fedora 15 and Firefox 6. I fixed that by turning off some plug-ins. Try disabling all plug-ins and if that helped turn them on one-by-one to see which one is the troublemaker.

more options

Posting here as I have the same problem also. Ubuntu 11.04, 64 bit, Firefox updated itself to v6 and most webpages are unusuable.

Tried turning off the acceleration if FF preferences, no joy. Have tried a number of suggestions, including Flash Aid, still no joy.