Αναζήτηση υποστήριξης

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why doesn't zoom gesture in Lion work in Firefox web pages?

  • 11 απαντήσεις
  • 275 έχουν αυτό το πρόβλημα
  • 2130 προβολές
  • Τελευταία απάντηση από DaveyJake

more options

I have latest Firefox and now the latest OS X: Lion. But the pinch to zoom gesture (which works in Safari) will not work in Firefox web pages. I thought Firefox was upgraded to work with Lion. So why not the zoom or is there something I need to do to FF to get this feature to work?

Επιλεγμένη λύση

This appears to be a problem firefox are aware of and are working on, and with some possible workarounds, see also thread: "Back/Forward Gestures do not work in Mac OS X Lion" -> /questions/853020

Ανάγνωση απάντησης σε πλαίσιο 👍 1

Όλες οι απαντήσεις (11)

more options

Επιλεγμένη λύση

This appears to be a problem firefox are aware of and are working on, and with some possible workarounds, see also thread: "Back/Forward Gestures do not work in Mac OS X Lion" -> /questions/853020

more options

Thanks John99. I sure hope that a fix will be coming soon. I really enjoy using Lion but I much prefer Firefox over Safari and would like to be able to use the functions of both together.

more options

Glad to have helped.

Unfortunately although I have so far stumbled across formal bug reports, and a reference to a rapid response team I have no idea where or when user friendly comments about this are likely to be made, all I can suggest is you watch any related threads for news.

more options

I had this problem with my browser as well. I'm using OS X 10.6.8 but, Try this: type the following into the address bar: about:config Then use the filter (top left side) and type the word, Gesture. Make the following changes to the following 2 fields: browser.gesture.pinch.in ~ enter the field and type, cmd_fullZoomReduce browser.gesture.pinch.out ~ enter the field and type, cmd_fullZoomEnlarge

These changes should immediately restore the pinch gestures you are used to. Try it as soon as you make the changes and let us know. I've included a screenshot.

Note the changes in the 2 line and make them. This worked for me. Good luck.

Τροποποιήθηκε στις από το χρήστη webserf

more options

Thanks for the help Webserf and for the screenshot! This looks like it did the trick so far and so good. I hope it sticks. I appreciate your response.

more options

Glad it helped , soulseeker!

I've restarted my computer and Firefox several times after the change, and it seems to be sticking. Hope it works out the same for you~

~Webserf

more options

Everything was fine before the update to Lion so only conclusion is that this update is the epicenter of the problem. In Safari all of the gestures are available I am running FF 5.0.1, none of the gestures work in this browser but the least inconvenient loss is turning pages. I hope someone fixes this soon. I find FF to be procrastinators when the group of negative experience is small, but Mac users pale in comparison to Windows users DON'T LEAVE US MAC USERS HANGING HERE PLEASE

more options

CraZSxYBitcH , The solution has been posted above, in the "Helpful" answer section. Good luck, I hope the solution works for you as well.

~webserf

more options

cmd_fullZoomReduce works! cmd_fullZoomEnlarge DOES NOT work!

Looks like the second command is not right...

more options

cmd_fullZoomEnlarge works!

more options

Another temporary fix to ensure that you don't zoom out and shrink the page items beyond its default size is to do the following in about:config:

Double-click browser.gesture.pinch.in and change it to cmd_fullZoomReset

However, should you want to zoom out and shrink the page items, do the following:

Double-click browser.gesture.pinch.in.shift and change it to cmd_fullZoomReduce

Granted you're just switching two values but makes zoom feel more Safari-like sotospeak.

Τροποποιήθηκε στις από το χρήστη DaveyJake