Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

Issue with multiple line breaks happening for every newline

  • 2 απαντήσεις
  • 0 έχουν αυτό το πρόβλημα
  • 10 προβολές
  • Τελευταία απάντηση από cor-el

more options

I've got an issue on several websites in 115b2 (but it's been an issue since at least 112) where Firefox inserts a bunch of
after a single newline. I've tried toggling editor.use_div_for_default_newlines, which had fixed this back in 92 when set to false. But now, true or false, I'm getting a bunch of line breaks when I'm not expecting them. This is only an issue in Firefox, Chrome/Edge does not have this behavior when using WYSIWYG editors. I can go back into the editor and clean out the additional line breaks without them being resubmitted, though.

example, there should only be a single line break between "message" and "more message":

message.


more message

I've got an issue on several websites in 115b2 (but it's been an issue since at least 112) where Firefox inserts a bunch of <br> after a single newline. I've tried toggling editor.use_div_for_default_newlines, which had fixed this back in 92 when set to false. But now, true or false, I'm getting a bunch of line breaks when I'm not expecting them. This is only an issue in Firefox, Chrome/Edge does not have this behavior when using WYSIWYG editors. I can go back into the editor and clean out the additional line breaks without them being resubmitted, though. example, there should only be a single line break between "message" and "more message": <div id="post_message_6522511"> message.<br> <br> <br> more message </div>

Όλες οι απαντήσεις (2)

more options

Sigh. I didn't know the support board would literally translate my html, sorry for the double entry:

I've got an issue on several websites in 115b2 (but it's been an issue since at least 112) where Firefox inserts a bunch of /br> after a single newline. I've tried toggling editor.use_div_for_default_newlines, which had fixed this back in 92 when set to false. But now, true or false, I'm getting a bunch of line breaks when I'm not expecting them. This is only an issue in Firefox, Chrome/Edge does not have this behavior when using WYSIWYG editors. I can go back into the editor and clean out the additional line breaks without them being resubmitted, though.

example, there should only be a single line break between "message" and "more message": /div id="post_message_6522511"> message/br> /br> /br> more message //div>

more options

The editor.use_div_for_default_newlines pref is no longer supported in 112 and newer and this setting now defaults to opening a new DIV when you press the Enter key. To get a line break (LF), you need to use Shift + Enter like also works in the developer tools (Web Console) to enter multiple lines via the command line (Enter works as an execute).