Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

need upgrade

  • 3 απαντήσεις
  • 0 έχουν αυτό το πρόβλημα
  • 2 προβολές
  • Τελευταία απάντηση από James

more options

need update cannot join zoom meeting

need update cannot join zoom meeting

Όλες οι απαντήσεις (3)

more options

Yes, you do need to upgrade.  ;-))

more options

Windows XP is end-of-life since about ten years. You definitely need an upgrade to Windows 10/11 or some Linux.

more options

lorieshleman said

need update cannot join zoom meeting

https://support.mozilla.org/en-US/kb/end-support-windows-xp-and-vista

Unfortunately Firefox 52.9.0esr was that last to still support the then EOL Windows XP and Vista.

Right now Firefox 115.0 ESR is the last to still support the EOL Windows 7, 8, 8.1 (until 115.15.0esr in Sept 2024) as Fx 116.0 and later requires Windows 10 or later.

The only other option you have is to try a dual boot with a light Linux distro with a lighter desktop environment like XFCE vs the heavier Gnome or KDE. Though 32-bit Linux distros are much less common now compared to 64-bit.