Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

Disable horizontal scrolling

  • 4 απαντήσεις
  • 0 έχουν αυτό το πρόβλημα
  • 61 προβολές
  • Τελευταία απάντηση από cor-el

more options

Is there any way I can completely disable horizontal scrolling? I'm using a laptop with a trackpoint (lenovo x230, Windows 10) and it's not terribly accurate, which means scrolling whilst a youtube video is going often makes it track backwards or forwards, and another website I use uses a horizontal click to send me to the next page, which sucks. I would prefer to just be able to disable it entirely. Thanks!

I swear to god I used to have it disabled, just need to work out how again.

Is there any way I can completely disable horizontal scrolling? I'm using a laptop with a trackpoint (lenovo x230, Windows 10) and it's not terribly accurate, which means scrolling whilst a youtube video is going often makes it track backwards or forwards, and another website I use uses a horizontal click to send me to the next page, which sucks. I would prefer to just be able to disable it entirely. Thanks! I swear to god I used to have it disabled, just need to work out how again.

Επιλεγμένη λύση

There are no windows 10 drivers that work for it, it requires a very specific driver number to work properly (here for posterity). I'm not using a touchpad, it's a physical scroll button and a trackpoint which when I accidently drag sideways a little (very easy with a trackpoint) it scrolls to the side instead.

I found out how to disble it in windows 7. Regedit to HKEY_Current_USER\Control Panel\Desktop then set WheelScrollChars to 0, but predictably, this doesn't work in Windows 10.

What did finally work was this: [https://superuser.com/questions/16112.../preventing-unwanted-horizontal-scrolling-with-synaptics-ultranav-driver-thinkpa]

Summarised, it's not doing what I thought it was. It's sending left/right key events, for some reason. /shrug

Going to a text file tp4table.dat , located in C:\Program Files\Synaptics\SynTP and putting a ; to comment out the Firefox line fixes the problem.

Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (5)

more options

That sounds more like a Driver issue then a Browser setting. You need to check and make sure that is the latest version for that Laptop driver or else uninstall and reinstall the trackpoint driver again. If the problem persist then you need to contact Lenovo for support for hardware issues.

Χρήσιμο;

more options

It's... Not? I'm on the drivers that work for windows 10, everything is fine, except sometimes I drag the trackpoint a little to the side instead of perfectly up and down and it horizontal scrolls instead of vertical.

The mouse is working as intended, I just firefox to stop accepting those inputs.

Τροποποιήθηκε στις από το χρήστη koco1

Χρήσιμο;

more options

That's a Windows 7 computer and loading wrong drivers for it is the likely issues going here. You need to verify that there are windows 10 drivers for it. And check with Lenovo support first.

Τροποποιήθηκε στις από το χρήστη Dropa

Χρήσιμο;

more options

With a normal mouse you would have to press the Shift key to scroll horizontal and the issue that you have wouldn't occur. Apparently with your touchpad you can scroll in both directions. I don't know if there is a way to limit scrolling with a touchpad to only scroll vertically in Firefox.

Χρήσιμο;

more options

Επιλεγμένη λύση

There are no windows 10 drivers that work for it, it requires a very specific driver number to work properly (here for posterity). I'm not using a touchpad, it's a physical scroll button and a trackpoint which when I accidently drag sideways a little (very easy with a trackpoint) it scrolls to the side instead.

I found out how to disble it in windows 7. Regedit to HKEY_Current_USER\Control Panel\Desktop then set WheelScrollChars to 0, but predictably, this doesn't work in Windows 10.

What did finally work was this: [https://superuser.com/questions/16112.../preventing-unwanted-horizontal-scrolling-with-synaptics-ultranav-driver-thinkpa]

Summarised, it's not doing what I thought it was. It's sending left/right key events, for some reason. /shrug

Going to a text file tp4table.dat , located in C:\Program Files\Synaptics\SynTP and putting a ; to comment out the Firefox line fixes the problem.

Τροποποιήθηκε στις από το χρήστη koco1

Χρήσιμο;

Υποβολή ερώτησης

Πρέπει να συνδεθείτε στον λογαριασμό σας για να απαντήσετε σε δημοσιεύσεις. Ξεκινήστε μια νέα ερώτηση εάν δεν διαθέτετε ακόμα λογαριασμό.