Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

Bookmark suggestions in URL bar: can I get suggestions only for exact URLs?

  • 4 απαντήσεις
  • 0 έχουν αυτό το πρόβλημα
  • 1 προβολή
  • Τελευταία απάντηση από pg_78

more options

In Settings, I have configured "When using the address bar, suggest..." to use my Bookmarks, and nothing else.

Let's say I have a bookmark for the URL: https://www.mozilla.org/en-GB/firefox/products/

If I start typing "moz", that bookmark appears in the suggestions, but the autocomplete also offers me the domain's "home" URL, https://www.mozilla.org.

I don't have that "home" URL bookmarked, so I don't want it to be suggested to me - as I told Firefox when I set "Bookmarks" as the only source of suggestions. Often when trying to navigate quickly to a bookmarked page, I assume that autocomplete will be giving me my bookmarked page, and end up accidentally going to the "home URL" instead.

So is there a setting that lets me keep my bookmark suggestions, but disable this "autocomplete with home URL" behaviour?

This isn't specific to mozilla.org: that URL was just an example.

In Settings, I have configured "When using the address bar, suggest..." to use my Bookmarks, and nothing else. Let's say I have a bookmark for the URL: https://www.mozilla.org/en-GB/firefox/products/ If I start typing "moz", that bookmark appears in the suggestions, but the autocomplete also offers me the domain's "home" URL, https://www.mozilla.org. I don't have that "home" URL bookmarked, so I don't want it to be suggested to me - as I told Firefox when I set "Bookmarks" as the only source of suggestions. Often when trying to navigate quickly to a bookmarked page, I assume that autocomplete will be giving me my bookmarked page, and end up accidentally going to the "home URL" instead. So is there a setting that lets me keep my bookmark suggestions, but disable this "autocomplete with home URL" behaviour? This isn't specific to mozilla.org: that URL was just an example.
Συνημμένα στιγμιότυπα

Τροποποιήθηκε στις από το χρήστη pg_78

Επιλεγμένη λύση

This is bug 1597791. Try to enter about:config in the URL bar, switch browser.urlbar.autoFill.adaptiveHistory.enabled = true and restart the browser.

Ανάγνωση απάντησης σε πλαίσιο 👍 1

Όλες οι απαντήσεις (4)

more options

Unfortunately I personally do not know how to force the URL bar auto-complete to only complete bookmarks.

One possible workaround that I use is to press the down key before pressing enter, to ensure that the first suggestion in the dropdown list is selected (assuming that the first is the one wanted).

So in your example you would type m o z down enter.

Sorry can't be more directly helpful. IF there is a way to achieve what you want, then hopefully someone else will share.

Τροποποιήθηκε στις από το χρήστη TechHorse

Χρήσιμο;

more options

TechHorse said

One possible workaround that I use is to press the down key before pressing enter, to ensure that the first suggestion in the dropdown list is selected (assuming that the first is the one wanted).

Ha, I hear you! Thanks for replying...let's see if anyone knows of a setting for it somewhere.

Τροποποιήθηκε στις από το χρήστη pg_78

Χρήσιμο;

more options

Επιλεγμένη λύση

This is bug 1597791. Try to enter about:config in the URL bar, switch browser.urlbar.autoFill.adaptiveHistory.enabled = true and restart the browser.

Χρήσιμο;

more options

TyDraniu said

This is bug 1597791. Try to enter about:config in the URL bar, switch browser.urlbar.autoFill.adaptiveHistory.enabled = true and restart the browser.

That does the job perfectly! Really appreciate your help!

(Edit: I spoke a bit too soon. The "home" URLs do still come up sometimes, though it's better than it was. But thanks, anyway!)

Τροποποιήθηκε στις από το χρήστη pg_78

Χρήσιμο;

Υποβολή ερώτησης

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.