Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

Firefox messing up colours when uploaded to Facebook

  • 3 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 14 προβολές
  • Τελευταία απάντηση από glove99

more options

When uploading images to Facebook using Firefox on a windows 10 machine the image colours look washed out and greenish when viewed in On Facebook. Colour management is enabled in Firefox, the images are jpeg in sRGB colour space. It doesn’t matter if the images are viewed in Firefox or another browser or on a different device they look rubbish. However, if I upload them using edge or another browser they look fine, both in the that and in Firefox. So somehow the Firefox interface with Facebook is messing up the colours. I’m now having to use a different browser to upload to Facebook. Does anyone know what’s going ok? Thans

When uploading images to Facebook using Firefox on a windows 10 machine the image colours look washed out and greenish when viewed in On Facebook. Colour management is enabled in Firefox, the images are jpeg in sRGB colour space. It doesn’t matter if the images are viewed in Firefox or another browser or on a different device they look rubbish. However, if I upload them using edge or another browser they look fine, both in the that and in Firefox. So somehow the Firefox interface with Facebook is messing up the colours. I’m now having to use a different browser to upload to Facebook. Does anyone know what’s going ok? Thans

Όλες οι απαντήσεις (3)

more options

A bit of Googling finds that colour management is switched off by default in Firefox [I'm not even going to comment on what I think of that idea;)

To enable it...

type about:config in the address bar & hit Enter. It warns you you're going into some 'advanced' mode, accept. Type gfx in the search bar that appears. Scroll down until you find gfx.color_management.enablev4 & click the icon to the right to set it to true Below that, set gfx.color_management.mode to 1 by clicking on the pencil icon Leave force srgb at false & rendering intent at 0 You should end up with this…

Quit & relaunch.

Tadaahhh!

Essentially, using those settings means it will use the embedded profile if there is one, or assume sRGB if there isn't - which is about as sensible as you can get for untagged files.

From comments I can't test this absolutely 'fresh' on Mac as I have had Firefox installed for a long time - though I have never really used it & certainly never set up management before - so I'd think off is default. On Windows 10 with a brand new install, never before seen on that machine - default is definitely off.

Χρήσιμο;

more options

Thanks for the suggestion. Sadly colour management IS enabled. I’m a photographer and have used Firefox correctly colour managed for years. Is just in a past few months that this problem has arisen.

Χρήσιμο;

more options

Also given that I’m using sRGB from you you say it should default to this even if there is a problem reading the profile. Yet still it’s messing something up.

Χρήσιμο;

Υποβολή ερώτησης

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.