Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

WidevineCdm plugin has crashed

  • 3 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 16 προβολές
  • Τελευταία απάντηση από jonzn4SUSE

more options

Whenever I attempt to access DRM content such as netflix or spotify I am notified that the WidevineCdm plugin has crashed. I'm running firefox version 101.0.1 on Kubuntu 22.04, I am running the debian package release, but I had this issue with the snap version too. I've submitted crash reports, but they're all "EMPTY: no crashing thread" (https://crash-stats.mozilla.org/report/index/20af09a5-6bc4-4719-9242-38f5c0220614 here's one).

Whenever I attempt to access DRM content such as netflix or spotify I am notified that the WidevineCdm plugin has crashed. I'm running firefox version 101.0.1 on Kubuntu 22.04, I am running the debian package release, but I had this issue with the snap version too. I've submitted crash reports, but they're all "EMPTY: no crashing thread" (https://crash-stats.mozilla.org/report/index/20af09a5-6bc4-4719-9242-38f5c0220614 here's one).

Επιλεγμένη λύση

The issue was resolved when I uninstalled the debian version, and then reinstalled the snap version. The snap version of firefox I had installed was the default when I installed Kubuntu. The steps I followed to install the debian version were:

  1. Removed the snap version using snap disable and snap purge (snap disable firefox; snap remove --purge firefox)
  2. added apt-repository ppa:mozillateam/ppa
  3. Edited /etc/apt/preferences.d/99mozillateamppa to disable the snap package and make the apt ppa package have priority
  4. ran (apt install -t 'o=LP-PPA-mozillateam' firefox)

/etc/apt/preferences.d/99mozillateamppa at this point contained Package: firefox* Pin: release o=LP-PPA-mozillateam Pin-Priority: 501 Package: firefox* Pin: release o=Ubuntu Pin-Priority: -1

These steps resulted in the issue as described above. I took a few more troubleshooting steps of deleting browser history and cookies, clearing startup cache, and uninstalling/reinstalling the debian installation of firefox while deleting my profile directory in-between installations. All of these steps still resulted in the same issue. The steps I followed to reinstall the snap version were:

  1. apt remove firefox and autoremove (apt remove firefox; apt autoremove)
  2. Edited /etc/apt/preferences.d/99mozillateamppa to remove the apt ppa package and instead make the snap package have priority
  3. Installed firefox using snap install (snap install firefox)

/etc/apt/preferences.d/99mozillateamppa now contains Package: firefox* Pin: release o=Ubuntu Pin-Priority: 501

I had resolved the issue prior to receiving the notification for this reply, so I apologize for not marking it as resolved and posting this earlier. I'm not sure what circumstances resulted in this snap installation being successful, I'm sorry I can't provide more useful information

Ανάγνωση απάντησης σε πλαίσιο 👍 1

Όλες οι απαντήσεις (3)

more options

Can we get the exact steps to replicate the issue? Try downloading Firefox from Mozilla, run it from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Χρήσιμο;

more options

Επιλεγμένη λύση

The issue was resolved when I uninstalled the debian version, and then reinstalled the snap version. The snap version of firefox I had installed was the default when I installed Kubuntu. The steps I followed to install the debian version were:

  1. Removed the snap version using snap disable and snap purge (snap disable firefox; snap remove --purge firefox)
  2. added apt-repository ppa:mozillateam/ppa
  3. Edited /etc/apt/preferences.d/99mozillateamppa to disable the snap package and make the apt ppa package have priority
  4. ran (apt install -t 'o=LP-PPA-mozillateam' firefox)

/etc/apt/preferences.d/99mozillateamppa at this point contained Package: firefox* Pin: release o=LP-PPA-mozillateam Pin-Priority: 501 Package: firefox* Pin: release o=Ubuntu Pin-Priority: -1

These steps resulted in the issue as described above. I took a few more troubleshooting steps of deleting browser history and cookies, clearing startup cache, and uninstalling/reinstalling the debian installation of firefox while deleting my profile directory in-between installations. All of these steps still resulted in the same issue. The steps I followed to reinstall the snap version were:

  1. apt remove firefox and autoremove (apt remove firefox; apt autoremove)
  2. Edited /etc/apt/preferences.d/99mozillateamppa to remove the apt ppa package and instead make the snap package have priority
  3. Installed firefox using snap install (snap install firefox)

/etc/apt/preferences.d/99mozillateamppa now contains Package: firefox* Pin: release o=Ubuntu Pin-Priority: 501

I had resolved the issue prior to receiving the notification for this reply, so I apologize for not marking it as resolved and posting this earlier. I'm not sure what circumstances resulted in this snap installation being successful, I'm sorry I can't provide more useful information

Χρήσιμο;

more options

Cool. Just mark it as resolved, but I would keep a copy from Mozilla to compare for future issues.  ;-)

Χρήσιμο;

Υποβολή ερώτησης

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.