Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

Sams club website saying that firefox is unsupported works in chrome ok

more options

I used to have no issues with this site www.samsclub.com but a few months ago it started to say that my up to date firefox was unsupported. Chrome works just fine. I did a firefox refresh with no joy. I use ABP and no script on both chrome and firefox and on both browsers i have disabled them for sams club, chrome works and firefox still says unsupported. I have tried user agent switcher, various configurations with no joy. I have turned off avast. no joy.

I used to have no issues with this site www.samsclub.com but a few months ago it started to say that my up to date firefox was unsupported. Chrome works just fine. I did a firefox refresh with no joy. I use ABP and no script on both chrome and firefox and on both browsers i have disabled them for sams club, chrome works and firefox still says unsupported. I have tried user agent switcher, various configurations with no joy. I have turned off avast. no joy.

Επιλεγμένη λύση

It's working under another user that has no add-ons right? Is Avast disabled while under the new user?

Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (14)

more options

It works. see screenshot Disable Avast, reboot and try again? Did you already try Firefox in Safe Mode?

Τροποποιήθηκε στις από το χρήστη jonzn4SUSE

more options

Avast was turned off per above safe mode made no change

more options

wulfman11 said

I used to have no issues with this site

Can you provide a screenshot of this issue?

more options

wulfman11 said

Avast was turned off per above safe mode made no change

Can you disable Avast, reboot and try again? While it's disabled, try a different Windows account and see what happens.

more options

very weird. i uploaded a screen shot on first post, or i thought i did, for some reason its not uploading an image.

I created another user and with a fresh copy of firefox it does work.

that solves that but it does not fix the issue on my main sign in.

how does one debug this kind of issue

it worked a few months ago and i have not installed any addons or anything

more options

Επιλεγμένη λύση

It's working under another user that has no add-ons right? Is Avast disabled while under the new user?

more options

avast was enabled I loaded up firefox and signed in I let it populate all my addons sams club worked fine

Its only on this login even after a refresh

I suppose i can delete it all and reinstall

but it would really be nice to see why its failing before giving up

more options

Well I removed everything firefox and reinstalled. Let it populate all addons and everything works. It's too bad there was no way to troubleshoot this before i had to do the drastic measure of a reinstall.

more options

So after a month it happened again, so i deleted all of firefox again reinstalled it and it is working again. Sure cant figure this one out. Its something long term causing this. Wish i know what sams club is checking or how its checking the browser.

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

Except that today after a reinstall with all addons functioning its fine.

more options

So this morning i tried to look at my solar charge controllers. for some reason the pages would not render. I had left samsclub on a tab and refreshed the tab and all was fine. So i shutdown firefox and restart it and my solar charge controllers displayed fine but the sams club site failed. i have been doing some checking and found a site that shows the same error and says it can be caused by CSS media queries. Now who knows who is at fault here the browser or the website owner but at least i am narrowing it down a bit.

https://nibbler.insites.com/en_US/reports/www.samsclub.com

more options

Did you try this in a new profile without modifications ?

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.


Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

more options

as seen above it works fine as another user and i just tried it again and its working. Must be something in my profile that gets messed up Not sure how i can delete the profile and restart over. I suppose i can try to save everything. passwords and bookmarks and somehow tell mozilla not to restora the old profile