Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

Multiple instances of Firefox spamming my computer, even with no pages open

  • 21 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 35 προβολές
  • Τελευταία απάντηση από Browzilla

more options

When I open Firefox, I'm getting ** 12 ** instances of Firefox opening up and spamming the hell out of my hard drive (even slowing down other processes), even without opening a page (I have mine set to not open any pages on loading Firefox). This is annoying and intolerable. I have looked around to find a workaround, but the only post was from last year, and gives instructions to turn off recommended settings, then says to set Firefox instances to 1, where there is no way to do that in that section on the version I'm running. So, how do I fix this? I want the hard drive spamming stopped.

When I open Firefox, I'm getting ** 12 ** instances of Firefox opening up and spamming the hell out of my hard drive (even slowing down other processes), even without opening a page (I have mine set to not open any pages on loading Firefox). This is annoying and intolerable. I have looked around to find a workaround, but the only post was from last year, and gives instructions to turn off recommended settings, then says to set Firefox instances to 1, where there is no way to do that in that section on the version I'm running. So, how do I fix this? I want the hard drive spamming stopped.

Όλες οι απαντήσεις (20)

more options

Also, it's not letting me upload an image of my process tree, for some dumb reason. It just keep the loading graphic cycling and not doing anything for over 4 minutes.

Τροποποιήθηκε στις από το χρήστη Browzilla

Χρήσιμο;

more options

Yes! The upload server is a pain in @#$!!!

Χρήσιμο;

more options

After rebooting the computer and logging in, before you run Firefox, is there already processes showing in the task manager? What happens if you run Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#w_how-to-start-firefox-in-4troubleshoot-modesf5safe-modesf

Χρήσιμο;

more options

There are many other processes when I reboot, but none of them are Firefox.

When I run Firefox in Safe Mode, there are 5 instances of Firefox, one parent and 4 child processes.

Χρήσιμο;

more options

If you notice you have more content processes than in the past then Fission is probably enabled. Fission is about a new site isolation architecture in Firefox and you will see more Firefox processes running than before and when Fission is enabled you can no longer limit the number of content processes in Settings or via dom.ipc.processCount on the about:config page. You can check the current Fission state on the "Help -> More Troubleshooting Information" (about:support) page (search for Fission).

It is quite normal to see more Firefox processes running.

  • process for the main Firefox thread (user interface)
  • one or more content processes
    you see more content processes when Fission is enabled
  • process for the compositor thread
  • process for extensions
  • process for WebRender when this feature is enabled

You can find the current multi-process state on the Troubleshooting Information page (about:support).

  • "Help -> Troubleshooting Information"
    "Application Basics": Multiprocess Windows
    "Remote Processes" further down

See also the about:memory and about:processes pages for information about the process IDs.

Χρήσιμο;

more options

So, how do I keep Firefox from spamming my hard drive?

Χρήσιμο;

more options

Spamming.... What does that mean? How many windows and tabs do you normally have open when running Firefox? I have 3 windows with 50 or more tabs open. My daily driver laptop dual boots Win7 and openSUSE and I have know issues.

What are the specs of you desktop? Processor? Ram? HD or SSD?

Operating System: openSUSE Tumbleweed 20220116 KDE Plasma Version: 5.23.5 KDE Frameworks Version: 5.90.0 Qt Version: 5.15.2 Kernel Version: 5.16.0-1-default (64-bit) Graphics Platform: X11 Processors: 4 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa DRI Intel® HD Graphics 4600

Τροποποιήθηκε στις από το χρήστη jonzn4SUSE

Χρήσιμο;

more options

I have ONE window open, and if you'll look at the image I uploaded, there are 11 instances of Firefox in my process tree (and only one tab open). When I open Firefox, they start spamming my hard drive to the point where everything else slows to a crawl or stops, until later when it's done doing whatever it's doing (God forbid I open YouTube, then everything stops because of the hundreds of MB being downloaded). It didn't used to happen when it was just the one instance running at a time. It's been going on for at least a month, and I'm sick of it. It's so bad that I have to wait 30+ seconds before any YouTube video actually runs, and hitting refresh doesn't help.

When I open Firefox with no home page, as I always do, it should load whatever little bit of memory Firefox needs, and THAT'S IT. No spamming my hard drive slowing everything else down, no opening a dozen instances and making it worse. One window, one process.

Processor: Intel(R) Core(TM) i7-5930K CPU @ 3.50GHz (12 CPUs), ~3.5GHz RAM: 32 GB HDD: 2TB, 187 GB free

Τροποποιήθηκε στις από το χρήστη Browzilla

Χρήσιμο;

more options

Did you check the support paged mentioned by cor-el? see screenshot Let me boot to Win7 and just open Firefox with no tabs and see how many processes are running.

Τροποποιήθηκε στις από το χρήστη jonzn4SUSE

Χρήσιμο;

more options

Here is what I get with Fission off and then on. see screenshots 1,2 This is a screenshot with a window that has 32 tabs and my system or other apps are not affected. see screenshot

Τροποποιήθηκε στις από το χρήστη jonzn4SUSE

Χρήσιμο;

more options

Open Chrome and see what you get with just 1 tab or several.

Χρήσιμο;

more options

I don't have Chrome installed, so I can't do that. I just uploaded a screenshot from opening about:support. I don't know what I'm looking at, so when I see 9 remote processes, I could be wrong in thinking that that is the problem. While I am computer-literate, and I used to be a programmer, I'm not familiar with the internal workings of Firefox's codebase. So, could you please cut out the extraneous stuff and just tell me why I'm getting 9 instances of Firefox running, as per the screen capture I uploaded? Your developer edition might work completely differently from the general release I'm running.

Χρήσιμο;

more options

It's what cor-el mentioned earlier.... Fission. Make it false and see what you get.

Τροποποιήθηκε στις από το χρήστη jonzn4SUSE

Χρήσιμο;

more options

I can't change any of the fission-related values in about:support. I click on them, but it won't allow me to change them. One of them said "experimental" in reference to fission, so I'm figuring that my standard release version of Firefox is locked into fission, and I'm being used as a guinea pig to test this fission stuff. What else can I do?

Edit: I just upgraded to version 96.0.3 64-bit, and I still can't access fission-related values in about:support.

Τροποποιήθηκε στις από το χρήστη Browzilla

Χρήσιμο;

more options

You can control Fission via fission.autostart on the about:config page, true to enable and false to turn it off.

  • about:config => fission.autostart = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Χρήσιμο;

more options

Tried that, didn't work. Also tried setting "fission.openNonFissionWindowOption" to true. Restarted, and the attached pic is what I got - 7 instances of Firefox running. And now it won't let me upload the picture - is your server down at 10 pm or something? What shall I try next?

Χρήσιμο;

more options

Good old upload server.... smh

Χρήσιμο;

more options

Here's the pic.

Χρήσιμο;

more options

Any updates?

Χρήσιμο;

more options

cor-el said

You can control Fission via fission.autostart on the about:config page, true to enable and false to turn it off.
  • about:config => fission.autostart = false
https://hacks.mozilla.org/2021/05/introducing-firefox-new-site-isolation-security-architecture/ You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Update.... This was your update. You can turn it off if you feel it's a problem. End of update.

Τροποποιήθηκε στις από το χρήστη jonzn4SUSE

Χρήσιμο;

  1. 1
  2. 2
Υποβολή ερώτησης

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.