Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

Bing Image search forgets I disabled "Safe Search"

  • 3 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 42 προβολές
  • Τελευταία απάντηση από Franpa

more options

If I do a Bing Image Search, disable "Safe Search" and then repeat the same search, "Safe Search" is re-enabled. The same occurs if I Refresh the page. I've tried the following to resolve it:

1) Delete all cookies and site data for Bing. 2) Disable Enhanced Tracking Protection for Bing. 3) Add exceptions for Bing to all adblocker add-ons. 4) Using Bing while logged out of my Microsoft account.

Problem begun after the update to Firefox 95 or 96.

If I do a Bing Image Search, disable "Safe Search" and then repeat the same search, "Safe Search" is re-enabled. The same occurs if I Refresh the page. I've tried the following to resolve it: 1) Delete all cookies and site data for Bing. 2) Disable Enhanced Tracking Protection for Bing. 3) Add exceptions for Bing to all adblocker add-ons. 4) Using Bing while logged out of my Microsoft account. Problem begun after the update to Firefox 95 or 96.

Επιλεγμένη λύση

Are you changing your SafeSearch preference through the settings page? Unfortunately, Bing has not caught up with a change in Firefox 96 that conforms some of its cookie handling to work like Chrome and Edge. According to someone who analyzed the site, Bing needs to modify its cookies for Firefox to be like the ones for Chrome to make it with with the change: https://bugzilla.mozilla.org/show_bug.cgi?id=1750152#c19 (Note: please do not add comments to a bug unless you can help fix it.)

For now, try this (it worked for me in a test profile):

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(B) In the search box in the page, type or paste laxByDefault and pause while the list is filtered

Firefox should list two matching preferences:

  • network.cookie.sameSite.laxByDefault
  • network.cookie.sameSite.laxByDefault.disabledHosts

(C) Double-click the network.cookie.sameSite.laxByDefault.disabledHosts preference to display an editing field, and enter www.bing.com and then press Enter or click the blue check mark button to save the change.

Can you save changes on Bing after that?

Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (3)

more options

You need to retain cookies and site settings for the option to be retained. That's what websites use cookies for. Others have reported the same issue with Bing so perhaps it is a problem with that website.

Χρήσιμο;

more options

Επιλεγμένη λύση

Are you changing your SafeSearch preference through the settings page? Unfortunately, Bing has not caught up with a change in Firefox 96 that conforms some of its cookie handling to work like Chrome and Edge. According to someone who analyzed the site, Bing needs to modify its cookies for Firefox to be like the ones for Chrome to make it with with the change: https://bugzilla.mozilla.org/show_bug.cgi?id=1750152#c19 (Note: please do not add comments to a bug unless you can help fix it.)

For now, try this (it worked for me in a test profile):

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(B) In the search box in the page, type or paste laxByDefault and pause while the list is filtered

Firefox should list two matching preferences:

  • network.cookie.sameSite.laxByDefault
  • network.cookie.sameSite.laxByDefault.disabledHosts

(C) Double-click the network.cookie.sameSite.laxByDefault.disabledHosts preference to display an editing field, and enter www.bing.com and then press Enter or click the blue check mark button to save the change.

Can you save changes on Bing after that?

Χρήσιμο;

more options

Yes that seems to have worked, thank you!

Χρήσιμο;

Υποβολή ερώτησης

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.