Αναζήτηση στην υποστήριξη

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

homepage

  • 7 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 19 προβολές
  • Τελευταία απάντηση από cor-el

more options

Hi, I just would like that whenever I open the browser, it would open my saved homepages. If I turn off the computer without closing firefox then the next time I open the browser it will load my previous session. I dont want to load my previous session, I want it to open my homepages every time. I have already unchecked "restore previous session" in the options. It only works if I close the firefox before turning off the computer. Just, please, tell me which option I should uncheck in about:config.

Όλες οι απαντήσεις (7)

more options

Are you shutting down the computer properly, or just hitting the power switch? If the latter, computers don't like that. It could cause damage to the hard drive. Not to mention programs won't be able to save their data.


Note: If you don't shut down Firefox properly, it may think it crashed and try to restore the previous session.

Χρήσιμο;

more options

On Linux, Firefox has a special integration with the OS: if Linux sends Firefox a message to close because the system is shutting down, then Firefox will set a flag to do an automatic session restore the next time you start it. (I've lost track of the thread where I posted the details on this.)

I'm not aware of a workaround for bypassing that, but maybe someone else has heard of one.

Χρήσιμο;

more options

Thia might be about the presence and content of sessionCheckpoints.json in the profile folder.

Χρήσιμο;

more options

See also:

Χρήσιμο;

more options

FredMcD dijo

Are you shutting down the computer properly, or just hitting the power switch? If the latter, computers don't like that. It could cause damage to the hard drive. Not to mention programs won't be able to save their data. Note: If you don't shut down Firefox properly, it may think it crashed and try to restore the previous session.

Im shutting down properly =]

jscher2000 dijo

On Linux, Firefox has a special integration with the OS: if Linux sends Firefox a message to close because the system is shutting down, then Firefox will set a flag to do an automatic session restore the next time you start it. (I've lost track of the thread where I posted the details on this.) I'm not aware of a workaround for bypassing that, but maybe someone else has heard of one.
Thats exactly the case

cor-el dijo

See also:

config => browser.sessionstore.resume_session_once it was false, i turned into true, nothing happened. should i delete sessionCheckpoints.json?

Χρήσιμο;

more options

viniciusdelangelo said

cor-el dijo

See also:
config => browser.sessionstore.resume_session_once it was false, i turned into true, nothing happened. should i delete sessionCheckpoints.json?

The preference is always reset to false after the "one time restore." The problem is that it is getting set to true during shutdown. I suppose in theory you could try using a user.js file to permanently override preference to false. This could be a problem during updates and other restarts where restoring your session is normal.

Χρήσιμο;

more options

What is the content of sessionCheckpoints.json when you force Firefox to close this way ?

Χρήσιμο;

Κάντε μια ερώτηση

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.