Αναζήτηση στην υποστήριξη

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

Cannot stop Firefox using the address bar as a search function

  • 5 απαντήσεις
  • 3 έχουν αυτό το πρόβλημα
  • 49 προβολές
  • Τελευταία απάντηση από bpstorn

more options

When I try and use the search bar in google to search anything, what ever I type appears in the address bar instead. Sometimes it trys to create a URL for what I am typing and fails.

I want to stop Firefox from using the address bar as the means of searching. I have read solutions online about changing things in about:config, however, this is not working fully.

It will only work it only works if I open up a new window. If I try and open up a tab it returns to trying to create a URL from my search requirements.

I have also tried the preference screen and nothing in there resolves the problem either.

Επιλεγμένη λύση

If the problem is on the built-in Firefox Home / new tab page, there is a preference for this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

Success?

More info on about:config: Configuration Editor for Firefox.

Ανάγνωση απάντησης σε πλαίσιο 👍 3

Όλες οι απαντήσεις (5)

more options

Επιλεγμένη λύση

If the problem is on the built-in Firefox Home / new tab page, there is a preference for this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

Success?

More info on about:config: Configuration Editor for Firefox.

Χρήσιμο;

more options

Thank you, that has resolved the issue.

Χρήσιμο;

more options

Did not fix the issue for me. When I type an address into the address bar it still searches. I turned it off in the search section of the options, and I turned this thing off. It still uses the address bar as a search bar. this whole situation is infuriating too. I hate when a program aggressively does something I don't want it to as a "feature" and the only way to make it stop is something convoluted.

I realized the URL was wrong, and solved the issue. but still aggressive search use is annoying.

Τροποποιήθηκε στις από το χρήστη Maxwell

Χρήσιμο;

more options

Maxwell said

When I type an address into the address bar it still searches. I turned it off in the search section of the options, and I turned this thing off. It still uses the address bar as a search bar.

What do you want Firefox to do if you enter example into the address bar and press Enter?

(A) Open http://www.example.com/ (B) Display an error page that a server was not found for example

Here how you set up either of those:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

Disable searching to get (A):

(2) In the search box in the page, type or paste keyword.enabled and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

And disable fixup to get (B):

(4) In the search box in the page, type or paste fixup and pause while the list is filtered

(5) Double-click the browser.fixup.alternate.enabled preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox.

Χρήσιμο;

more options

I had this same very...extremely frustrating issue, though, I am not sure which was more frustrating that it was changed in the first place or that it cannot be easily turned off.

Χρήσιμο;

Κάντε μια ερώτηση

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.