Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

userChrome.css does not seem to be getting applied.

  • 9 απαντήσεις
  • 2 έχουν αυτό το πρόβλημα
  • 2203 προβολές
  • Τελευταία απάντηση από Engztrom

more options

I was following this reddit thread on how to remove the "your camera and microphone are being shared" popup, but it's having no affect.

I have set `toolkit.legacyUserProfileCustomizations.stylesheets` to true.

Here's the full contents of the userChrome.css file: ```

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

#webrtcIndicator {
  display: none;
}

```

I was following [https://www.reddit.com/r/firefox/comments/78pjz1/how_do_i_remove_this_microphone_indicator/ this reddit thread] on how to remove the "your camera and microphone are being shared" popup, but it's having no affect. I have set `toolkit.legacyUserProfileCustomizations.stylesheets` to true. Here's the full contents of the userChrome.css file: ``` <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); #webrtcIndicator { display: none; }</nowiki></pre><br> ```

Τροποποιήθηκε στις από το χρήστη cor-el

Επιλεγμένη λύση

You did create the file in the correct location ?

  • ~/.mozilla/firefox/<profile&gt/chrome/userChrome.css;

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (9)

more options

Did you also verify that the file doesn't have a hidden .txt file extension (userChrome.css.txt) ?

You can try to add the !important flag.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

#webrtcIndicator {
  display: none !important;
}
more options

ls -l doesn't show any hidden extensions.

Added important flag, restarted Firefox, still not working.

more options

Does other CSS code in the file work ?

Is this with Firefox from the Mozilla server or Firefox from the software repositories ?

more options

It doesn't seem to. I tried adding a red border to the popup, but it didn't appear.

I'm not sure where to check, but I'm using Debian and apt says Firefox is not installed so probably the Mozilla version.

more options

Does something like this work ?

.urlbar-input-box {font-size:14pt!important; font-family:"DejaVu Sans Mono"}
more options

No, it doesn't. Tried with a few fonts and sizes.

more options

Επιλεγμένη λύση

You did create the file in the correct location ?

  • ~/.mozilla/firefox/<profile&gt/chrome/userChrome.css;

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

Well this was a pretty silly issue then. I had it in .mozilla/chrome.

Thanks for the help!

more options

I have the same problem, with Firefox 89.0.1 (64-bit) on Windows 10. As far as I can tell everything is correctly configured (see below), but it has no effect whatsoever in Firefox!

I have set toolkit.legacyUserProfileCustomizations.stylesheets to true, and userChrome.css file is put here: C:\Users\<my name>\AppData\Roaming\Mozilla\Firefox\Profiles\hjpksha1.default\chrome\ which is the catalog pointed out by Firefox in the help menu.

And the userChrome.css file looks like this: @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

/* Bookmarks sidebar: */ 
#bookmarks-view {
  font-size: 10pt !important;
  padding: 9px !important;
  margin-top: 0px !important;
  margin-bottom: 0px !important;
}
#bookmarks-view treechildren::-moz-tree-row {
  min-height: 12px !important;
  margin-top: 0px !important;
  margin-bottom: 0px !important;
}

/* Bookmarks from main menu: */
#bookmarksMenuPopup menu,
#bookmarksMenuPopup menuitem {
  font-size: 10pt !important; 
  min-height: 16px !important;
  max-height: 16px !important;
  margin-top: 0px !important;
  margin-bottom: 0px !important;
}

/* Bookmarks Toolbar: */
#PersonalToolbar {
  font-size: 10pt !important;
  margin-bottom: 3px !important;
}  
#PersonalToolbar menu,
#PersonalToolbar menuitem {
  font-size: 10pt !important;
  min-height: 16px !important;
  max-height: 16px !important;
  margin-top: 0px !important;
  margin-bottom: 0px !important;
}


My goal with this tweak is to reduce the annoying double linespacing in the bookmarks menu that was introduced in the latest Firefox version, but nothing is changed!