Αναζήτηση στην υποστήριξη

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

Disable redirect to https

  • Καμία απάντηση
  • 1 έχει αυτό το πρόβλημα
  • 1 προβολή
more options

I know this has come up many times before, I've read the solutions like this: https://support.mozilla.org/en-US/questions/1019210

But its old. There is also HSTS which Im not sure how that works and frankly, as a user I don't care.

We use internal websites on a company intranet domain. For example, a simple webpage to show the status of an application. I had to enable apache and made its config, so I know for a fact the site itself is not redirecting to https (other browsers aren't redirecting). Firefox insists on changing my address bar to https. When I use tcpdump or check the firewall, I dont even see port 80 traffic, firefox doesnt even try.

I tried the above, I also: - disabled addons (which I know dont redirect but to be sure) - erased the relevant history - deleted HSTS config file from my Mozilla profile - tried opening in a private window

The site above is an example, it happens with other sites too. Sometimes, it works for a while and then it stops. Sometimes, I find another site entry in the HSTS file, remove it and try again. Sometimes it works, sometimes it doesn't. I'm at a loss what to try next.

When I completely erase and start a new profile, without sync or addons, it might work but only for a short while. This isn't an option because literally, the only reason I still use firefox is because sync works reasonably well, across all devices, including most settings and addons.

I hope someone can help me fix this, I'd appreciate it!

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.