Αναζήτηση στην υποστήριξη

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

web browser problem

  • 7 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 13 προβολές
  • Τελευταία απάντηση από jscher2000

more options

my default web browser is Bing but when i enter a search in the Bing web browser it switches to Yahoo, is there any way to prevent that from happening?

Όλες οι απαντήσεις (7)

more options

Hi, this kind of hijack usually is caused by an unwanted extension, or by external malware. Let's start with the extensions:

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

Note: If the page is blank, you will need to use Firefox's Safe Mode for this cleanup. Steps below the line.

Assuming there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Any improvement?


In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart. A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.) A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

That should allow you to use the Add-ons page without interference.

more options

I guess i should have specified that i am on a Mac OSX

more options

Yes, I gave you my Mac version, with notes for Windows users in parentheses in case they happen by.

more options

Hello, were you able to remove the hijacker? Since a few other users also report Yahoo hijackers each month, it would be helpful if you can update us on what you find.

more options

no, it still goes to Yahoo. If you find any answers to this problem please let me know. thanks

more options

See my reply here;

This is usually caused by an extension that overrides the default search engine setting. This extension may not be visible on the about:addons page, so you can check the "Help -> Troubleshooting Information" (about:support) page or start Firefox in Safe Mode to see if it shows that way.

Τροποποιήθηκε στις από το χρήστη cor-el

more options

Thanks, let's recap and check a few more things then.

Did Firefox behave any better in its Safe Mode? That should prevent extensions from running or controlling your settings.

If the problem still occurs in Firefox's Safe Mode, could you experiment with one of the other built-in search engines such as DuckDuckGo or Google to see whether address bar searches on that one get hijacked? See: Change your default search settings in Firefox.

Any difference?

Could you also open the following internal page to see whether there are any active policies controlling your Firefox:

about:policies

(Normally, this page says "The Enterprise Policies service is inactive.")