Αναζήτηση υποστήριξης

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

Forcing SSL is DRIVING ME CRAZY as a developer. Needs a disable option.

  • 3 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 19 προβολές
  • Τελευταία απάντηση από FredMcD

more options

Dear community,

I would like to bring up a topic that is DRIVING ME CRAZY. I am developer and frequently access my own services on unsecured http servers for testing. Spin up a new docker container, test it, tear it down. No SSL required, no time to mess with encryption.

But if you type in https just a single time for your http server, you are f*#&ed. Sorry for the wording, but this is how it is. You think "OH NO, WHAT DID I DO? NOT AGAIN!!!" Because it is just impossible to access the service with http in the future, Firefox has it locked to SSL (Domain and Port). But of course there is no SSL so it will NEVER work.

Latest example: JetBrains TeamCity. They have a simple Docker container I want to access with Firefox. I spin it up, connect with Firefox with http and it immediately tells me "Secure Connection Failed". WHAT? WHY? I typed http. Why secure? Why can't I simply connect? Using curl on CLI just gives me a beautiful HTML response.

I understand that for the majority of users SSL is a good thing. But shouldn't there at least be an OPTION to disable all this enforced SSL usage? My beloved Firefox is my everyday productivity killer. It makes me sad.

Συνημμένα στιγμιότυπα

Όλες οι απαντήσεις (3)

more options

‘ssl_error_rx_record_too_long’ or ‘cannot display the webpage’ Internet search; More often than not, you have something misconfigured!

Χρήσιμο;

more options

Thank you, I assume JetBrains ia a large enough company to provide a working Docker container. As I wrote, access via command line curl works fine with http, just Firefox automatically switches to https.

Χρήσιμο;

more options

Make sure you are not using any add-ons that force https.


Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Χρήσιμο;

Κάντε μια ερώτηση

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.