Αναζήτηση υποστήριξης

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

Opening attachments in Gmail

  • 8 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 21 προβολές
  • Τελευταία απάντηση από rsuchyta1

more options

I'm using Gmail in Firefox 80.0.1. When there is a Word or .pdf attachment on a gmail message, clicking on the attachment opens the dialogue box attached below. Despite checking the box, "Do this automatically for files like this from now on," the box continue to pop up with the next attachment on another email. Is there a way to make it "automatic?"

Συνημμένα στιγμιότυπα

Επιλεγμένη λύση

Here's how I tested:

(1) Set the default actions on the Options page to open in Word (see screenshot)

(2) Send myself a Word document as an attachment to a Gmail message

(3) Click the Download button on the attachment (see screenshot)

Firefox shows the Download dialog because Google uses Content-Disposition: attachment

(4) Turn on Content-Type Fixer and change the Content-Disposition Override setting as shown in my earlier reply screenshot

(5) Click the Download button on the attachment

Firefox saves the document to the Temp folder and launches it in Word.

Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (8)

more options

If you go to the Firefox settings page and scroll down to the Applications section, you should be able to set the default action for those types of files there.

Hope this helps.

Χρήσιμο;

more options

The automatic action is connected to a specific content type that is send by the server and is not about the file extension.

Χρήσιμο;

more options

The pop up selects the correct program to open the attachment, but is there a way to have the program automatically open the attachment each time that file type is attached (just as the check box implies)?

Χρήσιμο;

more options

It depends. Sites may "force" a download by setting

Content-Disposition: attachment

and in that case, Firefox will always shows that dialog.

There are some add-ons you can use to override this instruction from the server so that Firefox automatically follows the instructions on the Options page. For example, I created this one: https://addons.mozilla.org/firefox/addon/content-type-fixer/

After you click the Zzzz button to turn it on, then click the button again and select the second option in the Content-Disposition section (inline):

Χρήσιμο;

more options

Tried all the above, including deleting the handlers.json file and installing the Content-Type Fixer add-on (thank you). Still have the same problem: I can open Gmail attachments via the pop-up, it just won't happen automatically.

Χρήσιμο;

more options

Interestingly, in Chrome, the attachments open fine automatically.

Χρήσιμο;

more options

Επιλεγμένη λύση

Here's how I tested:

(1) Set the default actions on the Options page to open in Word (see screenshot)

(2) Send myself a Word document as an attachment to a Gmail message

(3) Click the Download button on the attachment (see screenshot)

Firefox shows the Download dialog because Google uses Content-Disposition: attachment

(4) Turn on Content-Type Fixer and change the Content-Disposition Override setting as shown in my earlier reply screenshot

(5) Click the Download button on the attachment

Firefox saves the document to the Temp folder and launches it in Word.

Χρήσιμο;

more options

I went through the Content-Disposition override instructions a second time and IT WORKED! Must have done something wrong the first go around. Thank you so much for the fix; now I'll be less aggravated every time I open a Word or pdf document from Gmail in Firefox. Too bad the fix isn't in the browser itself. Thanks again!

Χρήσιμο;

Κάντε μια ερώτηση

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.