Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

How to hide or disable vertical and horizontal scrollbars? in v79 of Firefox

  • 2 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 7 προβολές
  • Τελευταία απάντηση από dwatts5669

more options

How to hide or disable vertical and horizontal scrollbars? in v79 of Firefox for Linux. I have created a 'user.Chrome.css' file and placed it in the Firefox active profile. I can see that it runs/opens that css file, but nothing happens or changes.

We are trying to use the Firefox browser to open and display GUI screens for a project. No matter what css 'example' code I use, a thin scroll bar on the right side of the screen is always there. There is nothing to scroll to, as all the widgets (buttons, etc.) are continued one screen that fills the browser screen.

Maybe things has changed for v79, as the only examples I can find are for version 6**.

I am new to this, so as much 'basic' information would be helpful Thanks

How to hide or disable vertical and horizontal scrollbars? in v79 of Firefox for Linux. I have created a 'user.Chrome.css' file and placed it in the Firefox active profile. I can see that it runs/opens that css file, but nothing happens or changes. We are trying to use the Firefox browser to open and display GUI screens for a project. No matter what css 'example' code I use, a thin scroll bar on the right side of the screen is always there. There is nothing to scroll to, as all the widgets (buttons, etc.) are continued one screen that fills the browser screen. Maybe things has changed for v79, as the only examples I can find are for version 6**. I am new to this, so as much 'basic' information would be helpful Thanks

Όλες οι απαντήσεις (2)

more options

You would want to put the following CSS code into a userContent.css (not userChrome.css) file:

* {
    scrollbar-width: none !important;
}

That will remove all scrollbars from the entire Firefox browser.

If you only want the scrollbars hidden from your project's pages, the best idea is to include the CSS code in your project's CSS file.

more options

Wesley,

Thanks for the prompt reply, am just know getting back to the project.

History: We are returning to a project we did several years ago, we are using a small panel pc/touchscreen to display the HMI/GUI operator interface which contains multiple interface screens. At the time of the original project, we used Google Chromium as the browser and we able to use a built-in flag to disable the scrollbars when in kiosk mode. This time around, Chromium has removed that flag from the version that is downloaded with the custom install application. We determined when the flag was removed from Chromium, but am only able to downgrade Chromium to a much older version then previously used. The panel pc/touchscreen come preinstalled with Mozilla Firefox browser, so we are trying to use this browser. When the HMI/GUI is opened in Firefox kiosk mode, the vertical (up/dwn) scrollbar appears on the right side of all the screens, even though the screens are full sized and do not need to be scrolled.

The panel pc/touchscrren is installed with the following:

 Mozilla Firefox Browser – ver 79.0 (64bit), canonical – 1.0   |   Ubuntu 16.04 LTS (64bit) with Graphics [Intel HD Graphics 505 (Broxton)

I do not know if what we are trying to do will work with the Firefox/ubuntu versions combination.

userContext.css

  1. content browser {
  scrollbar-width: none !important;

}

Result: In brief, I tried your code in the ‘userContext.css’ file, I renamed all other ‘userChrome.css’ files just to make sure (I had the ‘userChrome.css’ file in multiple places when I was trying to determine the current User Profile.)

After I power cycled the pc/touchscreen, I went back and verified that the loading of the Firefox Browser opened the ‘userContext.css’ file. But there was no change in the browser, nor in the ‘kiosk’ mode for Firefox.

Thanks David Watts