Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Setting "Never Remember History" is now disabling all add-ons

  • 8 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 31 προβολές
  • Τελευταία απάντηση από cor-el

more options

My Add-ons are disabled and disappear from the tool bar everytime I try to use the privacy setting of "Never Remember History"

I spent a few hours going through the troubleshooting suggestions, safe modes, clean boots, (3) reinstalls, and I have isolated the problem down to this.

If I turn on Never Remember the icons disappear from the tool bar and the custom set up and they are disabled for all intensive purposes. They still appear as installed and active on the Add-on screens.

Is there a fix for this problem ?

Επιλεγμένη λύση

Hi Fallonjd,

I regenerated same problem in my PC and found fix for that.

  • Click on menu icon.
  • Click on options.
  • In left pane, you will find Privacy & Security menu.
  • In this menu, You will find History option.
  • Choose Use Custom Settings for History and then uncheck Always use private browsing mode.
  • And check all the below three options.

And, boom you will see that your problem will be fixed.

Thank You.

Ανάγνωση απάντησης σε πλαίσιο 👍 0

All Replies (8)

more options

hello fallonjd,

follow the step and supported link resolve your problem:

  1. Click on the menu button. to expand the menu panel.
  2. Click Add-ons. The Add-ons Manager page will open.
  3. Click. on the Add-ons Manager page and select Check for Updates. ...
  4. Click the "Restart now to complete installation" link if prompted.
  • for more information:

[https://support.mozilla.org/en-US/kb/re-enable-add-ons-disabled-when-upda...]


I hope resolve your problem then reply me back.

Thank you!

Helpful?

more options

Please Refresh but do this 1st:

   https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer
   https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles 

then

   https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings 

TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...:

   https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles 

If is your Profile :

   https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile
   http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox 

Note: Any customization will revert back to default, you will also need to reinstall Extensions.

Please let us know if this solved your issue or if need further assistance.

Helpful?

more options

Your first suggestion returned a "No Updates Available" message.

Your second set of instructions I have completed three times, as suggested in your trouble shooting instructions, before sending you a request for help

It still works fine as long as I do not click on "Never Remember History"

Helpful?

more options

Hi fallonjd,

Actually some things are the Extension makers responsibility.

But in this case as you saw it is not.

Please try a Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st:

https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles then

https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...:

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles If is your Profile :

https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox Note: Any customization will revert back to default, you will also need to reinstall Extensions.

Helpful?

more options

Επιλεγμένη λύση

Hi Fallonjd,

I regenerated same problem in my PC and found fix for that.

  • Click on menu icon.
  • Click on options.
  • In left pane, you will find Privacy & Security menu.
  • In this menu, You will find History option.
  • Choose Use Custom Settings for History and then uncheck Always use private browsing mode.
  • And check all the below three options.

And, boom you will see that your problem will be fixed.

Thank You.

Helpful?

more options

If you do want to use automatic private browsing AND extensions, you need to go to the Add-ons page and enable each add-on to run in private windows. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If an extension does not have a purple mask icon, click its title to show its Details page. Scroll down to the controls area and find this one and click Allow:

Run in Private Windows      (*) Allow   ( ) Don’t Allow


Firefox saves that change automatically, so you can return to the Extensions list and continue with the next one, etc.

Helpful?

more options

Firefox checks for new versions of your add-ons once a day and updates them automatically. You can manually check for new versions at any time.

*Click on the menu button new fx menu to expand the menu panel.
  • Click Add-ons. The Add-ons Manager page will open.
  • Click Add-on Tools Icon on the Add-ons Manager page and select Check for Updates. If Firefox finds updates, they will be downloaded automatically

https://support.mozilla.org/en-US/kb/re-enable-add-ons-disabled-when-upda...

Helpful?

more options

Sounds that you have set your extensions not to be enabled in Private Browsing mode.

You can set for extensions whether they are enabled or disabled in Private Browsing mode via their details window on the about:addons page.

Helpful?

Κάντε μια ερώτηση

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.