Αναζήτηση στην υποστήριξη

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

In the 'Manage Permissions' section, under 'Cookies and Site Data' I have configured Firefox to block Google and Youtube cookies. These are not being blocked.

  • 9 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 4 προβολές
  • Τελευταία απάντηση από jeff77

more options

I have the following entries in the 'Manage Permissions' section;

http://google.com Block https://google.com Block http://google.ca Block https://google.ca Block http://youtube.com Block http://youtube.ca Block

However, I still get a youtube.com cookie whenever I watch a video. How do I prevent this?

Aside - yes, I am aware that blocking this cookie breaks some youtube content - I'm good with that. Also, why do I need to put each website in twice? (for http and https) I can't really think of a scenario where I'd want to block one and permit the other.

Επιλεγμένη λύση

Removing the cookies.sqlite file didn't help. However, creating an entirely new profile did.

Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (9)

more options

jeff77 said

http://google.com Block
https://google.com Block

http://google.ca Block
https://google.ca Block

http://youtube.com Block

http://youtube.ca Block

... Also, why do I need to put each website in twice? (for http and https) I can't really think of a scenario where I'd want to block one and permit the other.

You don't need to enter the insecure addresses for those sites since they are not used, but you do need the secure addresses. Those are missing for Youtube.

Some time back, Firefox switched how permissions are handled internally from bare host names (www.example.com) to origins/principals (protocol://www.example.com). I don't remember the reasons, but that is how it is.

more options

So you only need these:

https://google.com Block
https://google.ca Block
https://youtube.com Block
https://youtube.ca Block

Τροποποιήθηκε στις από το χρήστη cor-el

more options

The missing https://youtube.com Block is a typo in my original message. I have that entry present, but every time I go to the youtube.com website, I see a youtube.com cookie present.

more options

Hi jeff77, when you are on YouTube, can you open the Storage Inspector tool in the lower part of the tab by pressing Shift+F9. Firefox should show all the cookies set in the current page. You can use the right-click context menu to remove them. Then reload the page (Ctrl+r, or Ctrl+Shift+r to bypass the cache) and see which ones come back. Are they set on a slightly different host name by any chance?

more options

Thanks, that's helpful. At least I can now see what data is being stored.

The domain used is slightly different - the cookie is under https://www.youtube.com, but the domain is listed as .youtube.com (yes, the dot in front is present) However, when I add both of those to the permissions list, the youtube cookies are still showing up every time I reload the page.

more options

Hmm, that's very strange. I wonder whether the cookie might be coming from a different context, i.e., not directly from the page. Do you have any add-ons that might be contacting YouTube in the background when you visit the site?

more options

jscher2000 said

Hmm, that's very strange. I wonder whether the cookie might be coming from a different context, i.e., not directly from the page. Do you have any add-ons that might be contacting YouTube in the background when you visit the site?

I do, yes. I have an Ad blocker and a script blocker. However, to see if those might be involved I disabled both, restarted Firefox and retried it. I saw the same behaviour.

more options

If clearing cookies didn't help then it is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.

  • rename/remove cookies.sqlite (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

You can also check the storage/default folder for a youtube folder.

more options

Επιλεγμένη λύση

Removing the cookies.sqlite file didn't help. However, creating an entirely new profile did.