Αναζήτηση υποστήριξης

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When window opens, it's not in Normal mode

  • 8 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 10 προβολές
  • Τελευταία απάντηση από cor-el

more options

Hello, I link many items to Pinterest from my page. In the past, when I clicked the Pinterest button, the new window would open up in normal mode. For some reason, now when I click it, it opens Normal (I guess), but it's a very small window. I've tried to resize it so it opens that way next time, but nothing saves. Do any of you have suggestions on how I can fix that? It's a pain having to resize the window every time. Thanks so much.

Όλες οι απαντήσεις (8)

more options

Hi info2152, generally speaking, when you open a link in a new window in Firefox, Firefox will mimic the source window:

  • link in maximized window => open in a maximized window
  • link in resizable window => open in a resizable window, similar size, position slightly offset

Is the link that gives you the small window just a regular link or is it possible that a script is specifying a particular window size? That doesn't seem like a useful thing for a script to do in this case, but it could happen on some sites.

I'm not completely clear on how Firefox chooses resizable window sizes in other cases, such as external links coming from a different application. That's because in nearly all cases, they open as a new tab in an existing window instead of a separate window.

- - - -

Sometimes the settings file that stores window dimensions becomes corrupted with nonsensical values. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in File Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstoreOLD.json. If you see a file named localstore.rdf, it's ancient now, you can delete it.

Start Firefox back up again. Can you regain control of resizable window sizes?

That mini-reset will hide the menu bar and bookmarks toolbar. You can use one of these methods to show the toolbar list and select the desired bars there:

  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap and release the Alt key to activate the menu bar temporarily.
  • in Customize mode > Toolbars button (see: Customize Firefox controls, buttons and toolbars)

To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.

Χρήσιμο;

more options

By the way on this --

info2152 said

It's a pain having to resize the window every time.

What method are you using? If you click maximize, Firefox hasn't learned what size you want. If you resize the window by stretching it out (use the mouse to pull from the corners) that can help set a new size for resizable windows down the road.

Χρήσιμο;

more options

I've done both, and neither works. It's very odd because it always worked, but suddenly it didn't. Not sure if Firefox updated or what, but I can't get it to save my changes. I've resized the window every way possible, but it doesn't save. It's annoying because I have so many items to post to Pinterest. It may just be something that I have to live with.

Χρήσιμο;

more options

Well darn. After all that I was holding out hope that it would work. Unfortunately, it didn't. Not sure. I may try to delete and reload Firefox to see if that does something. Thanks for the help. I really appreciate it.

Bob

Χρήσιμο;

more options

How are you launching the Pinterest window? Is it using an add-on (extension, bookmarklet, etc.)?

Χρήσιμο;

more options

It looks like a normal window to me (sorry, I'm no expert). I have to constantly resize it. I've attached a screen print for you.

Χρήσιμο;

more options

Thanks for the screenshot.

That is a limited-feature pop-up -- you can tell by the stripped down toolbar. By default, Firefox does not divert limited feature popups to a new tab instead of a new window, because they might be dialogs related to the page you were on. Is your preference to continue getting that in a popup or would a new tab work for you? With a new tab, we can bypass the problem of the window size. I'll list the setting for that below the line if you'd like to try it.

If you would like to still have a pop-up window, but of a more normal size, there might be a setting for that but I'd have to do some research and experimentation.

- - - - -

For the sake of completeness, I'm going to describe three related preferences:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste neww and pause while the list is filtered

(3) Review/Edit the preference values as follows (double-click the current value to open an editing field, and then when you're done, press Enter or click the blue checkmark to save the change):

(A) browser.link.open_newwindow - for links in Firefox tabs

This is the one that has a checkbox on the Preferences page:

  • 3 = divert new window to a new tab (default)
  • 2 = allow link to open a new window
  • 1 = force new window into same tab

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

By default, if a page sets width, height, or toolbars for a popup, Firefox will let it be a separate window. To force those into a tab as well, you can change this preference to 0:

  • 0 = apply the setting under (A) to ALL new windows (even script windows with limited features) <= Change to this
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

  • -1 = apply the setting under (A) to external links (default)
  • 3 = open external links in a new tab in the last active window
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page

To return to normal if things go haywire, there's an arrow-like reset button at the right end of each of those rows if it has a non-default value.

Also, I have a test page here: https://www.jeffersonscher.com/res/popit.html

Success?

Τροποποιήθηκε στις από το χρήστη jscher2000

Χρήσιμο;

more options

See also:

  • https://www.fxsitecompat.dev/en-CA/docs/2020/browser-ui-can-no-longer-be-controlled-with-window-open-features-parameter/

Χρήσιμο;

Κάντε μια ερώτηση

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.