Search Support

How not to check for updates in firefox esr ?

  • 4 απαντήσεις
  • 2 έχουν αυτό το πρόβλημα
  • 68 προβολές
  • Τελευταία απάντηση από ItsMe2

more options

I run firefox esr and i recently updated from 60 version to 68. Now i get a error message saying "firefox is unable to determine if there is an update available" probably because i have deleted the update url from the config. How do i stop it from checking for updates ?

All Replies (4)

more options

Επιλεγμένη λύση

Helpful?

more options

cor-el said

You can possibly do this via a policies.json file.

Well i created a polices.json in C:\Program Files\Mozilla Firefox\distribution and i wrote in it

{

 "policies": {
   "DisableAppUpdate": True
 }

}

And guess what. It didn't work. I thought it worked but it didn't. Anyway the good thing of updating to version 68 is that now i can transfer the settings to chrome and goodbye.

Τροποποιήθηκε στις από το χρήστη ItsMe2

Helpful?

more options

If Firefox reads policies.json then you should see this policy listed on about:policies#active If you do not see this policy then there is a problem with the policies.json file.

Make sure that the file is a JSON file and not a text file with a hidden .txt file extension. You can possibly open the file in a Firefox tab to see if the file is valid JSON

Helpful?

more options

cor-el said

If Firefox reads policies.json then you should see this policy listed on about:policies#active If you do not see this policy then there is a problem with the policies.json file. Make sure that the file is a JSON file and not a text file with a hidden .txt file extension. You can possibly open the file in a Firefox tab to see if the file is valid JSON

on about:policies it writes "The Enterprise Policies service is inactive."

policies.json is a json file not a txt file

When i drag and paste policies.json on firefox it writes "SyntaxError: JSON.parse: unexpected character at line 3 column 25 of the JSON data" Meaning the T the first letter of True is an error....

After feather research i found out that if i change the capital T with a t everything work just fine.... Also on about:policies i get the disableappupdate as true now.

So in case i won't get any more Error pop up windows thanks ;)

Helpful?

Κάντε μια ερώτηση

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.