Αναζήτηση υποστήριξης

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

Youtube autoplay videos when switching tabs (I don't want that)

  • 6 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 53 προβολές
  • Τελευταία απάντηση από Maitreya

more options

Okay, so before, when I loaded up 100+ Youtube videos, they stayed when switching tabs - no autoplay. Suddenly they decide to autoplay when switching tabs - note, I've not done anything to my settings or plugins. Fair enough, maybe you changed something (which you often do, without informing). So I check the options. It was on "Block audio", which obviously didn't work, so I tried "Block Audio and Video" - which WORKS, but now both the video is paused (which I want) AND the audio is set to mute (which I DON'T want) - so... what does it take to have Youtube wait for a click to start playing a video loaded in a background tab, but KEEP AUDIO ACTIVE, so I don't also have to unmute the damn video?

Επιλεγμένη λύση

Maybe check this pref on the about:config page.

  • media.block-autoplay-until-in-foreground

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Ανάγνωση απάντησης σε πλαίσιο 👍 2

Όλες οι απαντήσεις (6)

more options

Hi Langbakk!

Non-free non-trivial javascript code (malware) running on peoples computers can of course cause problems. Easy to understand. Mozilla (open and free code) does its best to keep you happy and safe.

If you still want to run the non-free malware your own way, then try to go to the menu, click preferences or settings, click on the lock, scroll down to "program", try changing "flash-video"-setting into "always ask"!

Now you should always be asked before a flash video javascript code (malware) is allowed to run on your computer. I hope this helped you.

Τροποποιήθηκε στις από το χρήστη Maitreya

more options

Hi again Langbakk! Did this advice solve your problem?

more options

What are you on about? There are no Flash videos on YouTube... Why do you change stuff that works, into stuff that doesn't work? Why not just have a "don't autoplay videos" without doing anything to audio? If I want to mute audio, I can do so myself.

more options

Επιλεγμένη λύση

Maybe check this pref on the about:config page.

  • media.block-autoplay-until-in-foreground

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

Not in front of the computer for a few days, but I'll check that out. Thanks for the tip

more options

Hi again Langbakk! Did cor-el's advice solve your problem?

Otherwise check this page out and come back here and tell us if you solved the problem or not!

https://support.mozilla.org/en-US/kb/block-autoplay