Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

If I start Firefox by clicking a link in another application or operating system a window without Menu Bar items is opened

  • 5 απαντήσεις
  • 6 έχουν αυτό το πρόβλημα
  • 34 προβολές
  • Τελευταία απάντηση από J.

more options

As stated in the title, everytime when I open a link in the operating system (i.e. clicking on a link in an email or opening a website with Alfred) while Firefox is not already running, the following happens:

1. Two Firefox windows are opened 2. One window opens the requested website (https://startpage.com in the Screenshots) but has no context items in the Menu Bar above. 3. The second opens at Home and has the items in the Menu Bar.

I am using Mac OS Catalina (multiple versions) and the issue persisted a complete reinstall (I wiped my hard drive and did a clean install) of the operating system. I tried mainstream Firefox 73.0 and Firefox Dev Edition latest beta 74.0b2. (Used `brew cask` to install) Also I do have another Mac on High Sierra that does not have this issue.

Συνημμένα στιγμιότυπα

Επιλεγμένη λύση

This is a known bug on Catalina.

  • Bug 1603956 - macOS Catalina: Menu labels missing when cold opening Firefox from link or other app

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Ανάγνωση απάντησης σε πλαίσιο 👍 1

All Replies (5)

more options

Start Firefox in Safe Mode first {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh).

Then try using a link. Is the problem still there?

Helpful?

more options

Επιλεγμένη λύση

This is a known bug on Catalina.

  • Bug 1603956 - macOS Catalina: Menu labels missing when cold opening Firefox from link or other app

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Helpful?

more options

Hello How long should be WAIT until this BUG is fixed by Firefox? [[Bug 1603956|https://bugzilla.mozilla.org/show_bug.cgi?id=1603956]] Regards Phil

Helpful?

more options

https://bugzilla.mozilla.org/show_bug.cgi?id=1612653#c36 Verified - fixed on Firefox RC 74.0

Helpful?

more options

This bug still persists. On the aforementioned bug 1603956 the tracking flags end with firefox 76 fix optional. I am on beta 78.0b4 and the bug remains.

Helpful?

Κάντε μια ερώτηση

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.