X
Πατήστε εδώ για μετάβαση στην έκδοση της ιστοσελίδας για κινητές συσκευές.

Φόρουμ υποστήριξης

Content is not drawn on the entire screen on Linux

Δημοσιεύτηκε

Sometimes, when I open the browser, ALL content is not drawn to the window size, as shown in the screenshot. In this case, mouse events are tracked as if everything was drawn correctly, i.e., to the entire size. Only resizing the window helps. How to fix this problem? This happens not only in KDE, but also in GNOME. Clearing the profile didn't help. Running without extensions too. Such a problem still sometimes occurs. OS: ArchLinux https://imgur.com/a/X7Ue9Al

Sometimes, when I open the browser, ALL content is not drawn to the window size, as shown in the screenshot. In this case, mouse events are tracked as if everything was drawn correctly, i.e., to the entire size. Only resizing the window helps. How to fix this problem? This happens not only in KDE, but also in GNOME. Clearing the profile didn't help. Running without extensions too. Such a problem still sometimes occurs. OS: ArchLinux https://imgur.com/a/X7Ue9Al
Παράθεση

Επιπρόσθετες λεπτομέρειες συστήματος

Εγκατεστημένα αρθρώματα

TouchVPN, Mate translate, tabliss

Εφαρμογή

  • Πλατφόρμα χρήστη: Mozilla/5.0 (X11; Linux x86_64; rv:72.0) Gecko/20100101 Firefox/72.0

Περισσότερες πληροφορίες

FredMcD
  • Top 10 Contributor
4396 λύσεις 61654 απαντήσεις
Δημοσιεύτηκε

Have you tried resizing the window?

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Have you tried resizing the window? [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Σάς φάνηκε χρήσιμο;
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

FredMcD said

Have you tried resizing the window? Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Yes, as I wrote, resizing the window helps.

When starting in safe mode, this problem does not appear.

''FredMcD [[#answer-1288436|said]]'' <blockquote> Have you tried resizing the window? [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? </blockquote> Yes, as I wrote, resizing the window helps. When starting in safe mode, this problem does not appear.
Σάς φάνηκε χρήσιμο;
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

Also, there is no problem when the window is not open to full screen.

Also, there is no problem when the window is not open to full screen.
Σάς φάνηκε χρήσιμο;
Παράθεση
FredMcD
  • Top 10 Contributor
4396 λύσεις 61654 απαντήσεις
Δημοσιεύτηκε

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.
Σάς φάνηκε χρήσιμο;
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

Okay, I disabled hardware acceleration... It only got worse. https://imgur.com/a/4lzpxOe Disabling all extensions didn't help too.

Okay, I disabled hardware acceleration... It only got worse. https://imgur.com/a/4lzpxOe Disabling all extensions didn't help too.
Σάς φάνηκε χρήσιμο;
Παράθεση
FredMcD
  • Top 10 Contributor
4396 λύσεις 61654 απαντήσεις
Δημοσιεύτηκε

I called for more help.

It's possible the problem is a setting.


https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.

I called for more help. It's possible the problem is a setting. https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, '''resets some settings''', and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.
Σάς φάνηκε χρήσιμο;
Παράθεση
Κάντε μια ερώτηση

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.