Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

Paste Values Only (Ctrl+Shift+V) stopped working from Excel (desktop) to Google Sheets

  • 7 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 10 προβολές
  • Τελευταία απάντηση από jscher2000 - Support Volunteer

more options

Our company made the decision to abandon Microsoft Office products and move everything to G Suite. As part of the Analytics department, this has caused quite a few challenges. We had an Excel template to produce a report that is used frequently. The template was moved to Google Sheets and the challenge has been that the output from the software produces the information in such a way that a simple copy and paste to Google Sheets does not bring in the correct data. We figured out that using Paste Values Only (Ctrl+Shift+V) corrected the problem and was sufficiently convenient to use. However, that function has just stopped working.

It seems to coincide with the end of our licensing for MS Office products, but it only affects Firefox, and continues to work in Chrome. I am trying to figure out what the problem is, but have been unable to find a solution online. Any ideas?

Όλες οι απαντήσεις (7)

more options

I don't have a good way to test this myself. Can you explain how the value output is formatted? (E.g., would a string of comma separated values be similar?) Does it work if you use the Edit menu and mouse instead?

The keyboard shortcuts should be operating according to the page, and Firefox shouldn't interfere with these. If it does, that's a bug, and well worthy of reporting.

more options

crankygoat said

I don't have a good way to test this myself. Can you explain how the value output is formatted? (E.g., would a string of comma separated values be similar?) Does it work if you use the Edit menu and mouse instead?

Sorry for my cursory information. I can tell you how to recreate the issue easily.

The report output is a simple .csv file, which is easily opened with Excel. In fact, it is still easy to open with Excel, but we cannot manipulate it at all in Excel because we no longer have licensing and it will not let us. Since we need to get the data into Sheets, the simplest option we had (for clinician users not very savvy with technology) was for them to open file with Excel, and then copy and paste the data into the pre-formatted report template. (This report has one tab for the data, and another for the printable output that arranges the data and color codes things such as green/red for meeting or not meeting particular time goals, etc.)

Some of the output on the CSV file are date/time fields. In Excel, when dates or date/times do not have enough room to display, Excel will show ###### in their stead. The strange issue with Sheets is that if you copy and paste this information, Sheets will only get ###### and NOT the underlying date information. However, if you paste values or use Ctrl+Shift+V, then the date information is correctly carried to Sheets. Of course, you could also take the time to resize all the date columns so the dates display BEFORE copying and pasting, and that will also carry over the proper values, but like I said, these users can struggle with written instructions to press Ctrl+Shift+V, for example.

To answer your other question, no, using the mouse to click the Edit menu and select paste special and values only, or right clicking and doing the same thing directly into the cell also does not work. All of these were working in Firefox just last week for me and my teammates, but we just discovered it stopped working this week. These all work normally in Chrome.

The keyboard shortcuts should be operating according to the page, and Firefox shouldn't interfere with these. If it does, that's a bug, and well worthy of reporting.

I agree. I can't tell if the end of my MS Office license somehow affected this change, or if something changed in Firefox, or if some strange group policy has been enforced. It really feels (kind of conspiracy theory-like) that our transition to G Suite has caused several hidden things to be implemented to force us to use everything Google and to break any thing that could be considered competing software, etc.

Τροποποιήθηκε στις από το χρήστη Chaz D'Acquisto

more options
more options

I wonder if this would help, if not already enabled:

You can use shortcuts for spreadsheets made by other companies in Google Sheets. On your computer, open a spreadsheet at sheets.google.com. At the top, click Help and then Keyboard shortcuts. At the bottom of the window, turn on Enable compatible spreadsheet shortcuts.

- If you use an extension to view your docs with Google, can they simply be saved as a Google sheet and merged with an existing sheet if necessary? https://addons.mozilla.org/en-US/firefox/addon/google-docs-viewer/

Edit: I cannot replicate the issue, but i don't have a copy of Excel here, and the most recent version of Office i have anywhere is 2k3. Using Libre Office i don't have issues with Ctrl+v or Ctrl+Shift+v.

Is there a chance you can directly import your CSV (or even XLSX, if you can save the file) directly into Google Sheets? (Alternatively, you can try with a copy of Libre Office if it will help, Calc is the spreadsheet application.)

Τροποποιήθηκε στις από το χρήστη crankygoat

more options

Please ignore: this does not work across from Excel to Sheets.

I realize it's an extra click or two, but for a multi-cell paste, have you tried using the menu item? Either:

  • (Google Sheets menu bar) Edit > Paste Special > Paste values only
  • right-click the upper left cell > Paste Special > Paste values only

Τροποποιήθηκε στις από το χρήστη jscher2000 - Support Volunteer

more options

Upon further review:

I get the ## characters when I paste from Excel to Word, so it seems to be something about the formats that Excel puts on the clipboard.

The only way I can reliably paste values without having to expand columns is to use Notepad as an intermediary:

  • Select and copy in Excel
  • Paste into Notepad (this pastes a tab-separated text format)
  • Select and copy in Notepad
  • Paste into Sheets

Or maybe Sheets can open CSV files directly, but I haven't researched that.

more options

As an alternative hack-around, you could try this:

  • Select and copy in Excel
  • In Google Sheets, click the cell where you want to paste
  • Use Insert > Note (or right-click Insert note), then Paste (Ctrl+v)
  • Select the entire note contents (Ctrl+a) and cut (Ctrl+x)
  • Press Esc to close the note
  • Paste (Ctrl+v)

What that does is the same as using Notepad as an intermediary: it replaces the HTML format the browser prefers for Paste with the contents of the Plain Text format.

But yeah, no one wants to do that all day...