X
Πατήστε εδώ για μετάβαση στην έκδοση της ιστοσελίδας για κινητές συσκευές.

Φόρουμ υποστήριξης

FFv70: Can't disable urlbar suggestions again

Δημοσιεύτηκε

v70 seems to have reset my config settings and brought back the urlbar suggestions dropdown.

When I had this same problem back in v65, it was solved by going to about:config, search for "browser.urlbar.maxRichResults", and set the value to 0. FF V70 has reset the value to 10.

When I try to reset the value to 0, though, double-clicking on the value gives me a blank dropdown menu, and FF immediately locks-up (completely unresponsive and a beachballing cursor), and I have to force-quit. I get the same result by right-clicking the value and selecting Modify. So, now I'm stuck with the urlbar suggestions, and apparently I can't edit *any* config settings.

v70 seems to have reset my config settings and brought back the urlbar suggestions dropdown. When I had this same problem back in v65, it was solved by going to about:config, search for "browser.urlbar.maxRichResults", and set the value to 0. FF V70 has reset the value to 10. When I try to reset the value to 0, though, double-clicking on the value gives me a blank dropdown menu, and FF immediately locks-up (completely unresponsive and a beachballing cursor), and I have to force-quit. I get the same result by right-clicking the value and selecting Modify. So, now I'm stuck with the urlbar suggestions, and apparently I can't edit *any* config settings.

Επιλεγμένη λύση

Okay, it sounds as though you only have one profile.

The -1557763292617 on the folder name suggests it was created by a Refresh of your original "default" profile in May of this year. So even if you have a folder named "Old Firefox Data" on your Mac desktop, I wouldn't expect it to have anything recent. (But if you do, please take a look inside.)

Could you try:

New Profile Test

This takes about 3 minutes, plus the time to test about:config.

On the about:profiles page:

Click the "Create a New Profile" button, then click Next. Assign a name like Oct2019, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Does Firefox let you modify preferences in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (Oct2019 will remain available for future testing.)

Ανάγνωση απάντησης σε πλαίσιο 1
Παράθεση

Επιπρόσθετες λεπτομέρειες συστήματος

Εγκατεστημένα αρθρώματα

  • Shockwave Flash 32.0 r0

Εφαρμογή

  • Πλατφόρμα χρήστη: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:70.0) Gecko/20100101 Firefox/70.0

Περισσότερες πληροφορίες

jscher2000
  • Top 10 Contributor
8787 λύσεις 71864 απαντήσεις
Δημοσιεύτηκε

Hi Thorzdad, did your Firefox create a new profile?

You could check whether your normal settings are available in a different profile, as follows:

Profile Manager Page

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

This page should list at least one profile and could list many. (Each profile has two folders and one or more buttons. Do not use any Remove buttons!)

The profile that Firefox is currently using will have this:

This is the profile in use and it cannot be deleted.

Do you have another profile named default or default-longnumber listed on this page? If so, you can check whether it is the one you were using recently by clicking its Launch profile in new browser button.

If it isn't what you want, simply close that new window.

If it IS what you want, back on the about:profiles page, click the Set as default profile button for that profile so Firefox uses it automatically at the next startup.

Hi Thorzdad, did your Firefox create a new profile? You could check whether your normal settings are available in a different profile, as follows: '''Profile Manager Page''' Inside Firefox, type or paste '''about:profiles''' in the address bar and press Enter/Return to load it. This page should list at least one profile and could list many. (Each profile has two folders and one or more buttons. Do not use any Remove buttons!) The profile that Firefox is currently using will have this: '''This is the profile in use and it cannot be deleted.''' Do you have another profile named '''default''' or default-''longnumber'' listed on this page? If so, you can check whether it is the one you were using recently by clicking its '''Launch profile in new browser''' button. If it isn't what you want, simply close that new window. If it IS what you want, back on the about:profiles page, click the '''Set as default profile''' button for that profile so Firefox uses it automatically at the next startup.
Σάς φάνηκε χρήσιμο;
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

Thanks, jscher2000.

This is on a Mac.

When I go about:profiles, under Profile: default there's a table with the following entries:

Default Profile: Yes Root Directory: /Users/me/Library/Application Support/Firefox/Profiles/8l97256s.default-1557763292617 Local Directory: /Users/me/Library/Caches/Firefox/Profiles/8l97256s.default-1557763292617

Note that they point to the same folder but with different paths.

The only buttons on those listings are two Show in Finder buttons. Those link to where the Profile folders live. The Local Directory path leads to an empty folder. Only the Root Directory path points to a folder full of the expected files.

Below that table is a Rename button.

In the upper right of the window is a box labeled Restart. It has two buttons: Restart with addons disabled and Restart normally...

There is also a Create a New Profile button up near the top of the page.

There is no Launch profile in new browser button.

Thanks, jscher2000. This is on a Mac. When I go '''about:profiles''', under '''Profile: default''' there's a table with the following entries: '''Default Profile:''' Yes '''Root Directory:''' /Users/me/Library/Application Support/Firefox/Profiles/8l97256s.default-1557763292617 '''Local Directory: '''/Users/me/Library/Caches/Firefox/Profiles/8l97256s.default-1557763292617 Note that they point to the same folder but with different paths. The only buttons on those listings are two '''Show in Finder''' buttons. Those link to where the Profile folders live. The ''Local Directory'' path leads to an empty folder. Only the ''Root Directory'' path points to a folder full of the expected files. Below that table is a '''Rename''' button. In the upper right of the window is a box labeled '''Restart'''. It has two buttons: '''Restart with addons disabled''' and '''Restart normally...''' There is also a '''Create a New Profile''' button up near the top of the page. There is no ''Launch profile in new browser'' button.

Τροποποιήθηκε στις από το χρήστη Thorzdad

Σάς φάνηκε χρήσιμο;
Παράθεση
jscher2000
  • Top 10 Contributor
8787 λύσεις 71864 απαντήσεις
Δημοσιεύτηκε

Επιλεγμένη λύση

Okay, it sounds as though you only have one profile.

The -1557763292617 on the folder name suggests it was created by a Refresh of your original "default" profile in May of this year. So even if you have a folder named "Old Firefox Data" on your Mac desktop, I wouldn't expect it to have anything recent. (But if you do, please take a look inside.)

Could you try:

New Profile Test

This takes about 3 minutes, plus the time to test about:config.

On the about:profiles page:

Click the "Create a New Profile" button, then click Next. Assign a name like Oct2019, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Does Firefox let you modify preferences in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (Oct2019 will remain available for future testing.)

Okay, it sounds as though you only have one profile. The -1557763292617 on the folder name suggests it was created by a Refresh of your original "default" profile in May of this year. So even if you have a folder named "Old Firefox Data" on your Mac desktop, I wouldn't expect it to have anything recent. (But if you do, please take a look inside.) ''Could you try:'' '''New Profile Test''' This takes about 3 minutes, plus the time to test about:config. On the '''about:profiles''' page: Click the "Create a New Profile" button, then click Next. Assign a name like Oct2019, ignore the option to relocate the profile folder, and click the Finish button. After creating the profile, scroll down to it and click the '''Launch profile in new browser''' button. Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test. ''Does Firefox let you modify preferences in the new profile?'' When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (Oct2019 will remain available for future testing.)
Σάς φάνηκε χρήσιμο; 1
Παράθεση
cor-el
  • Top 10 Contributor
  • Moderator
17569 λύσεις 158914 απαντήσεις
Δημοσιεύτηκε

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

You can check for problems with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page

In case errors are reported with "Verify Integrity" close and restart Firefox and retry.

If "Verify Integrity" cannot repair places.sqlite, rename/remove all places.sqlite and favicons.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created

See also:

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

If you use Sync then best is to disconnect Sync temporarily during troubleshooting. You can check for problems with the <b>places.sqlite</b> and <b>favicons.sqlite</b> files in the Firefox profile folder. *use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page In case errors are reported with "Verify Integrity" close and restart Firefox and retry. If "Verify Integrity" cannot repair places.sqlite, rename/remove all <b>places.sqlite</b> and <b>favicons.sqlite</b> files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder. *keep a backup copy of places.sqlite in case a new places.sqlite database has to be created See also: *https://support.mozilla.org/en-US/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file *https://support.mozilla.org/en-US/kb/fix-bookmarks-and-history-will-not-be-functional You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *https://support.mozilla.org/en-US/kb/Profiles
Σάς φάνηκε χρήσιμο;
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

cor-el, I can modify configs using the new test profile. And, for whatever reason, I can now modify configs in my primary profile. Weird.

So, back to the original issue, disabling the urlbar suggestions dropdown. I was now able to switch browser.urlbar.maxRichResults to "0", which has almost completely eliminated the dropdown. Now, when I type in the urlbar, a very thin white bar drops down. It's about 5 or 6 pixels high, and extends across the full width of the browser window, not just the width of the urlbar. It's weird, but I guess I can live with it.

I'm still not seeing webpage titles up in the titlebar, but that's another discussion.

cor-el, I can modify configs using the new test profile. And, for whatever reason, I can now modify configs in my primary profile. Weird. So, back to the original issue, disabling the urlbar suggestions dropdown. I was now able to switch '''browser.urlbar.maxRichResults''' to "0", which has almost completely eliminated the dropdown. Now, when I type in the urlbar, a very thin white bar drops down. It's about 5 or 6 pixels high, and extends across the full width of the browser window, not just the width of the urlbar. It's weird, but I guess I can live with it. I'm still not seeing webpage titles up in the titlebar, [https://support.mozilla.org/en-US/questions/1271477 but that's another discussion.]
Σάς φάνηκε χρήσιμο;
Παράθεση
cor-el
  • Top 10 Contributor
  • Moderator
17569 λύσεις 158914 απαντήσεις
Δημοσιεύτηκε

You need to use a userChrome.css file to hide this small drop-down menu that you get with the pref set to 0 (zero).

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#urlbar-results { display: none !important; } /*hide drop down*/

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

You need to use a userChrome.css file to hide this small drop-down menu that you get with the pref set to 0 (zero). Add code to the <b>userChrome.css</b> file below the default @namespace line. <hr> <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #urlbar-results { display: none !important; } /*hide drop down*/ </nowiki></pre> ----- *https://www.userchrome.org/what-is-userchrome-css.html *https://www.userchrome.org/how-create-userchrome-css.html In Firefox 69 and later you need to set this pref to true on the <b>about:config</b> page to enable userChrome.css and userContent.css in the chrome folder. *toolkit.legacyUserProfileCustomizations.stylesheets = true *https://www.userchrome.org/firefox-changes-userchrome-css.html
Σάς φάνηκε χρήσιμο;
Παράθεση
Κάντε μια ερώτηση

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.