X
Πατήστε εδώ για μετάβαση στην έκδοση της ιστοσελίδας για κινητές συσκευές.

Φόρουμ υποστήριξης

How can I restore Google as my Default Search Engine when I open new tabs?

Δημοσιεύτηκε

For as long as I can remember, all my new tabs opened into a Google search window. But now, they open into a Search Mozilla Support window. That's not what I want -- I want to restore the Google search window.

I've checked the forums, and followed the advice on changing this: Settings > Search > One-Click Search Engines.

That doesn't work for me, because Mozilla Support is selected as my search engine, and the Restore Default Search Engines button is greyed out. When I click the tab for Find More Search Engines, there's no sign of Google.

Does Mozilla hate Google?

I'm using Firefox 69.0.2 on a 2017 iMac running OS Mojave, 10.14.5.

Thanks for any help!

For as long as I can remember, all my new tabs opened into a Google search window. But now, they open into a Search Mozilla Support window. That's not what I want -- I want to restore the Google search window. I've checked the forums, and followed the advice on changing this: Settings > Search > One-Click Search Engines. That doesn't work for me, because Mozilla Support is selected as my search engine, and the Restore Default Search Engines button is greyed out. When I click the tab for Find More Search Engines, there's no sign of Google. Does Mozilla hate Google? I'm using Firefox 69.0.2 on a 2017 iMac running OS Mojave, 10.14.5. Thanks for any help!
Συνημμένα στιγμιότυπα

Επιλεγμένη λύση

Hi rob26,

I'm sorry to hear the mixed results. Are you unable to launch the other profile in the About Profiles in about:profiles?

Ανάγνωση απάντησης σε πλαίσιο 0
Παράθεση

Επιπρόσθετες λεπτομέρειες συστήματος

Εγκατεστημένα αρθρώματα

  • Shockwave Flash 32.0 r0

Εφαρμογή

  • Πλατφόρμα χρήστη: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:69.0) Gecko/20100101 Firefox/69.0

Περισσότερες πληροφορίες

WMagicModel
  • Top 25 Contributor
  • Administrator
13 λύσεις 187 απαντήσεις
Δημοσιεύτηκε

Χρήσιμη απάντηση

Hi rob26,

Google is added by default as one of the search engines; you don't need to add it as an extension.

You will find a list of the default search engines installed with Firefox towards the end of this article : Search the Web on Firefox {link}

Have you tried restarting in Safe Mode? You may have an add-on that is interfering with your default search engine; using Safe Mode will disable any third party add-ons.

To start in Safe Mode :

  1. Click the '3-bar' menu icon in your Firefox web browser
  2. Click Help(?)
  3. Click Restart with Add-ons Disabled...
  4. Click Restart, when prompted choose Start in Safe Mode

Try modifying the settings in Safe Mode or try browsing the web to see if the problem has been solved.

Let me know if you're still having issues!

Hi rob26, Google is added by default as one of the search engines; you don't need to add it as an extension. You will find a list of the default search engines installed with Firefox towards the end of this article : [[Search the Web on Firefox]] {link} Have you tried restarting in '''Safe Mode'''? You may have an add-on that is interfering with your default search engine; using Safe Mode will disable any third party add-ons. To start in Safe Mode : # Click the '3-bar' '''menu''' icon in your Firefox web browser # Click '''Help(?)''' # Click '''Restart with Add-ons Disabled...''' # Click '''Restart''', when prompted choose '''Start in Safe Mode''' Try modifying the settings in Safe Mode or try browsing the web to see if the problem has been solved. Let me know if you're still having issues!

Τροποποιήθηκε στις από το χρήστη WMagicModel

Σάς φάνηκε χρήσιμο; 1
Παράθεση
jscher2000
  • Top 10 Contributor
8688 λύσεις 71027 απαντήσεις
Δημοσιεύτηκε

Hi rob26, if I understand your description correctly, your Preferences page, Search panel has:

Default search engine: Mozilla Support

One-click search engines: Mozilla Support

Restore Default Search Engines button: grayed out

This can occur if the settings file that stores the status of search engines has become corrupted. Unfortunately, what I'm going to suggest to address that will remove any OpenSearch search engines you may have added; any added through extensions should remain, although you might need to Enable/Disable the extension.

Search Engines Reset

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Return

In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default-release, double-click it to display the contents of that profile folder.

Leaving that window open, switch back to Firefox and Quit out (for example: Firefox menu > Quit).

Pause while Firefox finishes its cleanup, then rename search.json.mozlz4 to something like searchOLD.json.mozlz4.

Start Firefox back up again. It should rediscover the built-in search engines and allow you to modify the settings.

Does that work?

Hi rob26, if I understand your description correctly, your Preferences page, Search panel has: Default search engine: Mozilla Support One-click search engines: Mozilla Support Restore Default Search Engines button: grayed out This can occur if the settings file that stores the status of search engines has become corrupted. Unfortunately, what I'm going to suggest to address that will remove any OpenSearch search engines you may have added; any added through extensions should remain, although you might need to Enable/Disable the extension. '''Search Engines Reset''' Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste '''about:support''' in the address bar and press Return In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default-release, double-click it to display the contents of that profile folder. Leaving that window open, switch back to Firefox and Quit out (for example: Firefox menu > Quit). Pause while Firefox finishes its cleanup, then rename '''search.json.mozlz4''' to something like searchOLD.json.mozlz4. Start Firefox back up again. It should rediscover the built-in search engines and allow you to modify the settings. Does that work?
Σάς φάνηκε χρήσιμο;
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

WMagicModel said

Hi rob26, Google is added by default as one of the search engines; you don't need to add it as an extension. You will find a list of the default search engines installed with Firefox towards the end of this article : Search the Web on Firefox {link} Have you tried restarting in Safe Mode? You may have an add-on that is interfering with your default search engine; using Safe Mode will disable any third party add-ons. To start in Safe Mode :
  1. Click the '3-bar' menu icon in your Firefox web browser
  2. Click Help(?)
  3. Click Restart with Add-ons Disabled...
  4. Click Restart, when prompted choose Start in Safe Mode
Try modifying the settings in Safe Mode or try browsing the web to see if the problem has been solved. Let me know if you're still having issues!


I restarted with Add-ons disabled (didn't restart my computer though) and am still having the same problem.

''WMagicModel [[#answer-1258041|said]]'' <blockquote> Hi rob26, Google is added by default as one of the search engines; you don't need to add it as an extension. You will find a list of the default search engines installed with Firefox towards the end of this article : [[Search the Web on Firefox]] {link} Have you tried restarting in '''Safe Mode'''? You may have an add-on that is interfering with your default search engine; using Safe Mode will disable any third party add-ons. To start in Safe Mode : # Click the '3-bar' '''menu''' icon in your Firefox web browser # Click '''Help(?)''' # Click '''Restart with Add-ons Disabled...''' # Click '''Restart''', when prompted choose '''Start in Safe Mode''' Try modifying the settings in Safe Mode or try browsing the web to see if the problem has been solved. Let me know if you're still having issues! </blockquote> I restarted with Add-ons disabled (didn't restart my computer though) and am still having the same problem.
Σάς φάνηκε χρήσιμο;
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

jscher2000 said

Hi rob26, if I understand your description correctly, your Preferences page, Search panel has: Default search engine: Mozilla Support One-click search engines: Mozilla Support Restore Default Search Engines button: grayed out This can occur if the settings file that stores the status of search engines has become corrupted. Unfortunately, what I'm going to suggest to address that will remove any OpenSearch search engines you may have added; any added through extensions should remain, although you might need to Enable/Disable the extension. Search Engines Reset Open your current Firefox settings (AKA Firefox profile) folder using either
  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Return
In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default-release, double-click it to display the contents of that profile folder. Leaving that window open, switch back to Firefox and Quit out (for example: Firefox menu > Quit). Pause while Firefox finishes its cleanup, then rename search.json.mozlz4 to something like searchOLD.json.mozlz4. Start Firefox back up again. It should rediscover the built-in search engines and allow you to modify the settings. Does that work?

When I click the "Show in Finder" button, it opens to a Profiles folder called zdat8mk3.default. Does that offer any additional information that's useful?

''jscher2000 [[#answer-1258044|said]]'' <blockquote> Hi rob26, if I understand your description correctly, your Preferences page, Search panel has: Default search engine: Mozilla Support One-click search engines: Mozilla Support Restore Default Search Engines button: grayed out This can occur if the settings file that stores the status of search engines has become corrupted. Unfortunately, what I'm going to suggest to address that will remove any OpenSearch search engines you may have added; any added through extensions should remain, although you might need to Enable/Disable the extension. '''Search Engines Reset''' Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste '''about:support''' in the address bar and press Return In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default-release, double-click it to display the contents of that profile folder. Leaving that window open, switch back to Firefox and Quit out (for example: Firefox menu > Quit). Pause while Firefox finishes its cleanup, then rename '''search.json.mozlz4''' to something like searchOLD.json.mozlz4. Start Firefox back up again. It should rediscover the built-in search engines and allow you to modify the settings. Does that work? </blockquote> When I click the "Show in Finder" button, it opens to a Profiles folder called zdat8mk3.default. Does that offer any additional information that's useful?
Σάς φάνηκε χρήσιμο;
Παράθεση
jscher2000
  • Top 10 Contributor
8688 λύσεις 71027 απαντήσεις
Δημοσιεύτηκε

rob26 said

When I click the "Show in Finder" button, it opens to a Profiles folder called zdat8mk3.default. Does that offer any additional information that's useful?

My example of a1b2c3d4.default-release was just an example. You should look inside that zdat8mk3.default folder for the search.json.mozlz4 file.

''rob26 [[#answer-1258061|said]]'' <blockquote> When I click the "Show in Finder" button, it opens to a Profiles folder called zdat8mk3.default. Does that offer any additional information that's useful? </blockquote> My example of a1b2c3d4.default-release was just an example. You should look inside that zdat8mk3.default folder for the '''search.json.mozlz4''' file.
Σάς φάνηκε χρήσιμο;
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

jscher2000 said

rob26 said
When I click the "Show in Finder" button, it opens to a Profiles folder called zdat8mk3.default. Does that offer any additional information that's useful?

My example of a1b2c3d4.default-release was just an example. You should look inside that zdat8mk3.default folder for the search.json.mozlz4 file.


Got it, thanks.

I renamed the zdat8mk3.default folder as zdat8mk3OLD.default, quit Firefox, waited, then relaunched -- and got an error message, "Your Firefox profile cannot be loaded. It may be missing or inaccessible."

I order to relaunch Firefox, I had to revert back to the folder's original name, zdat8mk3.default.

I

''jscher2000 [[#answer-1258069|said]]'' <blockquote> ''rob26 [[#answer-1258061|said]]'' <blockquote> When I click the "Show in Finder" button, it opens to a Profiles folder called zdat8mk3.default. Does that offer any additional information that's useful? </blockquote> My example of a1b2c3d4.default-release was just an example. You should look inside that zdat8mk3.default folder for the '''search.json.mozlz4''' file. </blockquote> Got it, thanks. I renamed the zdat8mk3.default folder as zdat8mk3OLD.default, quit Firefox, waited, then relaunched -- and got an error message, "Your Firefox profile cannot be loaded. It may be missing or inaccessible." I order to relaunch Firefox, I had to revert back to the folder's original name, zdat8mk3.default. I
Σάς φάνηκε χρήσιμο;
Παράθεση
WMagicModel
  • Top 25 Contributor
  • Administrator
13 λύσεις 187 απαντήσεις
Δημοσιεύτηκε

Χρήσιμη απάντηση

Hi rob26,

You could try to create a new Profile if you haven't already.

To do this:

  1. Type about:profiles in the Firefox address bar.
  2. under About Profiles click Create a New Profile
  3. go through the Creation Wizard name the new profile as you wish.
  4. Once complete the new profile will be listed under the About Profiles and click Launch profile in new browser.

Reference article: Creating a profile {link}

Hi rob26, You could try to create a new Profile if you haven't already. To do this: # Type '''about:profiles''' in the Firefox address bar. # under ''About Profiles ''click '''Create a New Profile''' # go through the ''Creation Wizard ''name the new profile as you wish. # Once complete the new profile will be listed under the ''About Profiles ''and click''' Launch profile in new browser'''. Reference article: [https://support.mozilla.org/en-US/kb/profile-manager-create-remove-switch-firefox-profiles#w_creating-a-profile Creating a profile] {link}
Σάς φάνηκε χρήσιμο; 1
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

I did this. There's good news and bad news.

The good news is, it worked, and all my tabs now open to a Google search window, as they did before.

The bad news is, creating a new profile automatically de-selected the Restore Previous Session option in Firefox preferences, so when I restarted, all of my tabs were gone, including dozens I was using as research. And it emptied my search history, which means I can't find the sites I'd been using.

I did this. There's good news and bad news. The good news is, it worked, and all my tabs now open to a Google search window, as they did before. The bad news is, creating a new profile automatically de-selected the Restore Previous Session option in Firefox preferences, so when I restarted, all of my tabs were gone, including dozens I was using as research. And it emptied my search history, which means I can't find the sites I'd been using.
Σάς φάνηκε χρήσιμο;
Παράθεση
WMagicModel
  • Top 25 Contributor
  • Administrator
13 λύσεις 187 απαντήσεις
Δημοσιεύτηκε

Επιλεγμένη λύση

Hi rob26,

I'm sorry to hear the mixed results. Are you unable to launch the other profile in the About Profiles in about:profiles?

Hi rob26, I'm sorry to hear the mixed results. Are you unable to launch the other profile in the ''About Profiles ''in '''about:profiles'''?
Σάς φάνηκε χρήσιμο;
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

I didn't realize I could -- I thought that profile was gone.

So yes, I was able to launch it, and there are all my tabs intact*. And when I open a new tab, it delivers a Google search window, just as I wanted.

  • 250 tabs, though in my defense, many of those are in a OneTab tab.

Thanks, everyone. And thank you for walking me through it, WMagicModel.

I didn't realize I could -- I thought that profile was gone. So yes, I was able to launch it, and there are all my tabs intact*. And when I open a new tab, it delivers a Google search window, just as I wanted. *250 tabs, though in my defense, many of those are in a OneTab tab. Thanks, everyone. And thank you for walking me through it, WMagicModel.
Σάς φάνηκε χρήσιμο;
Παράθεση
WMagicModel
  • Top 25 Contributor
  • Administrator
13 λύσεις 187 απαντήσεις
Δημοσιεύτηκε

You're very welcome! You can always make a backup of each profile.

A helpful article for backing up profiles (sorry I forgot to post in the above post!)

Back up and restore information in Firefox profiles

You're very welcome! You can always make a backup of each profile. A helpful article for backing up profiles (sorry I forgot to post in the above post!) [[Back up and restore information in Firefox profiles]]
Σάς φάνηκε χρήσιμο; 1
Παράθεση
jscher2000
  • Top 10 Contributor
8688 λύσεις 71027 απαντήσεις
Δημοσιεύτηκε

rob26 said

jscher2000 said
My example of a1b2c3d4.default-release was just an example. You should look inside that zdat8mk3.default folder for the search.json.mozlz4 file.


Got it, thanks.

I renamed the zdat8mk3.default folder as zdat8mk3OLD.default, quit Firefox, waited, then relaunched -- and got an error message, "Your Firefox profile cannot be loaded. It may be missing or inaccessible."

I order to relaunch Firefox, I had to revert back to the folder's original name, zdat8mk3.default.

OMG Rob, you're supposed to rename the search.json.mozlz4 file, not your entire profile folder!

Well, I don't know exactly where things stand at this point. (Sorry I was away, I'm at work.)

''rob26 [[#answer-1258071|said]]'' <blockquote> ''jscher2000 [[#answer-1258069|said]]'' <blockquote> My example of a1b2c3d4.default-release was just an example. You should look inside that zdat8mk3.default folder for the '''search.json.mozlz4''' file. </blockquote> Got it, thanks. I renamed the zdat8mk3.default folder as zdat8mk3OLD.default, quit Firefox, waited, then relaunched -- and got an error message, "Your Firefox profile cannot be loaded. It may be missing or inaccessible." I order to relaunch Firefox, I had to revert back to the folder's original name, zdat8mk3.default. </blockquote> OMG Rob, you're supposed to rename the '''search.json.mozlz4''' file, not your entire profile folder! Well, I don't know exactly where things stand at this point. (Sorry I was away, I'm at work.)

Τροποποιήθηκε στις από το χρήστη jscher2000

Σάς φάνηκε χρήσιμο;
Παράθεση
McCoy
  • Top 10 Contributor
534 λύσεις 5035 απαντήσεις
Δημοσιεύτηκε

rob26 said

thank you for walking me through it, WMagicModel.

Hello rob26,

Would you be so kind as to mark WMagicModel's post (the one that solved the problem for you) as Chosen Solution ?

(it's the "Solved the problem" button to the right of his post)

Thank you in advance !

''rob26 [[#answer-1258103|said]]'' <blockquote> thank you for walking me through it, WMagicModel. </blockquote> Hello rob26, Would you be so kind as to mark WMagicModel's post (the one that solved the problem for you) as Chosen Solution ? (it's the "Solved the problem" button to the right of his post) Thank you in advance !
Σάς φάνηκε χρήσιμο;
Παράθεση
McCoy
  • Top 10 Contributor
534 λύσεις 5035 απαντήσεις
Δημοσιεύτηκε

Hello again rob26,

You had inadvertently marked my post as Chosen Solution - a moderator removed that mark from my post, but didn't mark WMagicModel's post as Chosen Solution .....

Would you be so kind as to try again ?

Hello again rob26, You had inadvertently marked ''my'' post as Chosen Solution - a moderator removed that mark from my post, but didn't mark WMagicModel's post as Chosen Solution ..... Would you be so kind as to try again ?
Σάς φάνηκε χρήσιμο;
Παράθεση
McCoy
  • Top 10 Contributor
534 λύσεις 5035 απαντήσεις
Δημοσιεύτηκε

McCoy said

Hello again rob26, You had inadvertently marked my post as Chosen Solution - a moderator removed that mark from my post, but didn't mark WMagicModel's post as Chosen Solution ..... Would you be so kind as to try again ?

Never mind; I just noticed that a moderator marked the correct post.

''McCoy [[#answer-1258539|said]]'' <blockquote> Hello again rob26, You had inadvertently marked ''my'' post as Chosen Solution - a moderator removed that mark from my post, but didn't mark WMagicModel's post as Chosen Solution ..... Would you be so kind as to try again ? </blockquote> Never mind; I just noticed that a moderator marked the correct post.
Σάς φάνηκε χρήσιμο; 1
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

Apologies to all -- I find the interface here a little confusing.

Apologies to all -- I find the interface here a little confusing.
Σάς φάνηκε χρήσιμο;
Παράθεση
McCoy
  • Top 10 Contributor
534 λύσεις 5035 απαντήσεις
Δημοσιεύτηκε

rob26 said

Apologies to all -- I find the interface here a little confusing.

Absolutely no apologies needed - and thank you for trying  !

''rob26 [[#answer-1258553|said]]'' <blockquote> Apologies to all -- I find the interface here a little confusing. </blockquote> Absolutely no apologies needed - and thank you for trying !
Σάς φάνηκε χρήσιμο;
Παράθεση
Κάντε μια ερώτηση

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.